System Won't Boot - Ultimate 15.3

AMD® Ryzen 5 2600 six-core processor × 12
16 gig RAM
Zorin OS 15.3 Ultimate
This morning I was prompted to update Zorin OS and a lot of other things. As usual, I clicked Install Now. I installed 15.2 on my new machine about 2 months ago. I also received and accepted update requests for libreoffice and keepassxc. I also completed those. These latter ones seem to have prompted 2 or 3 more notifications for updates to Zorin and more. I did them all. Then I was prompted to restart the machine to complete the updates. I did. The machine shutdown but did not start back up. A single white dash appeared on the screen, but the BIOS screen never appeared and nothing more happened. Eventually, I tried rebooting several times using the hardware button, but the BIOS screen never appeared. I then booted from the Zorin install mem stick. Now, Zorin says that it is 15.3 and KeepassXC says it is 2.6.2. It was 2.6.1 before I updated. I have never encountered a situation where the BIOS doesn’t seem to start up. What can I do?
Note: I just checked. I have a timeshift backup of the system from 2 days ago. I may have to go back to that.

By BIOS do I assume you mean the GRUB menu?
Is your machine dual-boot Window/Linux?
You could try “boot repair tool”. I had a similar problem a long time ago and ran that using default settings and it fixed my boot problem.
I am not sure if “boot repair tool” is maybe included in Zorin Live USB/DVD, you can check.

More info here:

My system is not dual-boot. Normally on startup the ASUS logo appears as the BIOS executes. Now, nothing appears except for what looks like a single white dash ‘-’. Then the dash disappears and nothing further is displayed. There is no opportunity to enter setup. I am not using grub. I did search the forums for help. There may be help there, but I did not find it.

Can you try the steps in this post: [SOLVED] Black screen after install ?
Additionally, please also check the settings here: Software Updater settings

Thank-you for your help. I attempted to reboot various times before posting my help request. I was unable to boot until I put the Zorin install mem stick that I made. That appears to have fixed it. Before trying your suggestions, I removed the stick and attempted to reboot again. The machine came up normally with one difference: the BIOS of the ASUS motherboard flashed its logo very quickly on and off before Zorin came up normally. Before, the Zorin updates today the ASUS logo appeared for much longer giving time to enter setup. I am not worried about this. Just to be clear this is a brand new machine that I put together about 2 months ago. Zorin OS 15.3 Ultimate is the only OS that has ever been on it. Over 20 years have passed since I last developed on a Unix OS. The memories are coming back faster than I expected. Also, I seem to have misspoke: I believe the first Zorin version that I installed was 15.3 … not 15.2. The version number did not change today with the updates.

On my desktop, I still have dual boot Win 7 (which also has boot control), so the logo is on for the same time.
On my wife’s desktop, there is slightly less time that the logo is on (she only has Zorin) before Zorin starts, than when she had Win 7.
Both are ASUS mobos.
So, it seems you should be fine with the logo duration change (although you did write that you’re fine with it).

Do you mean the Zorin installation stick was kept plugged-in to make it boot? That is interesting. And it didn’t go into Live mode, right? Now that you’re booting, are your Software Updater settings as in the second link I posted? And did you find anything new under “Additional Drivers”?

Thanks for noting that it was already on 15.3 - I’ll edit the thread title.

@JimH. My post was based on misunderstanding that it was GRUB menu that was not appearing, so ignore.
FYI. On my laptop, the BIOS screen appears for a few seconds, then GRUB menu appears, as I dual-boot.
Hope your boot to Z15.3 is now working properly, without any further need of your Live USB.

Thank-you zabadabadoo. My machine is now booting without the Live USB. I did nothing except to boot 1 time from the USB stick. I do not know how booting from the stick could fix this kind of boot issue, but I’ll take it.

I booted from the Live USB stick just one time, then removed it. When I booted from the stick I expected to see a menu allowing be to select between install, run from stick, etc., but it did not appear. Instead, the machine seemed to return to normal. I cannot understand how an update to Zorin OS could affect the very low-level BIOS software. I believe I am showing my age by calling it the BIOS. I appreciate your attention.

I believe what you’re referring to is the boot splash screen. But it is still strange that this would happen. At least if it made it to GRUB, then we know it is the video driver not loading.
Would you mind marking System Won't Boot - Ultimate 15.3 as the solution? Your solution may be very helpful to future readers. I will certainly keep it in mind should I encounter the same.