The End Of Life For Win 10 Coming Soon, Dilemma

Hello friends, sooner or later I will have to transition to Linux anyway, so I want to do it now.
My laptop is an older Acer Aspire E15 with a 256 GB SSD hard drive. I recently changed out my mechanical HD for an SSD because the mechanical was too slow. On that old drive I did run Zorin 16 Core and had no problems, but when I tried to put Zorin OS 17 Core on the machine I ran into problems. I burned the OS to a 15 Gig USB drive with Belena Etcher and tried to install with that. The installation went as expected up to the point of selecting try or install Zorin. I selected install and the installation wiped my drive and started the installation. So far, so good. Everything went fine until near the end the installation halted and would go no further. So, I was left with a wiped disk and no OS. I tried the installation three times, but it did not take. So, I put Win 10 back on since I needed to use the PC. Still, I want to go to Linux. Any ideas as to what I did wrong? Thanks.

I had this problem installing on a machine, and it was the pendrive.

Even though he passed the Balena and Zorin installer tests, the installation did not complete. In one of the attempts it even completed but then it wouldn't boot.

If you have another pendrive to test, that's an option.

1 Like

In addition to using a different pendrive, just to confirm is not faulty (although I suspect it may not be the case if you were able to revert back to Windows), you can try a different utility to create the drive bootable: Ventoy.

Also, take a look at these threads. Maybe they are not related, but it just might have the answer or point you in the right direction:

If nothing here works, don't be afraid of trying other distributions: MX Linux, Linux Mint, etc.

Update; after all is said and done on the installation, this is the error I get when I try to run Linux "Loading error; scrolled:
SQUASHFS Failed To Read block 0x58c8cf4b"

I would say this is caused by the pendrive, based on some threads that I found reporting similar errors:

Did you get a chance to try with another pendrive? Or try to burn the iso again, maybe even trying different tools than Balena this time. If you are doing this from Windows, Rufus is another popular alternative.

2 Likes

Very well, I will reformat my pen drive and reinstall. Thanks.

iv'e installed countless distros but never used a usb (pendrive) ,my machines were always old and still had a cd/dvd drive lol. I know latest machines doesn't even come out with disk drives ( :confounded: )
anyway if you have a disk drive just burn (pick slowest burn speed) the iso on a disk using xfburn , and when done ,boot from disk .
i never encountered problems

PS: i did once try installing with a usb and didn't work ...so , yea ...IDK

Also, while I've never personally had an issue, I've seen a lot of people across this forum and others complain about Belena Etcher; some say it corrupts / bricks their USB stick, others say that they have trouble booting from the USB or installing the flashed live environment. Using rufus (if you have an installed Windows OS) or dd (if you have an installed Linux OS) are preferable.

That said, I can't recommend Ventoy enough. I have two USB sticks flashed with Ventoy, one that stays at home and one I take with me on the go, containing tools like Super Grub2 Disk, Rescatux, GParted, and Clonezilla, along with a selection of Linux distro ISOs - Zorin Core and Lite, MX Linux, Fedora or Ultramarine, Kali, and 32bit LMDE.

It's surprising how often it comes in handy to have them ready-to-go, rather than having to spend time finding and flashing specific things at the moment you need them.

2 Likes

Does your E15 have a DVD-RW or is this just a DVD drive?

I used a now USB drive and put Ventoy on it and tried again but as the first time it goes all the way through the installation and at the end just goes blank and never completes without explanation this time. There is just something about my system that blocks Linux.
My CD drive stopped a while back put I do have a USB external CD drive. I tried the CD route but all of my Cds are write protected. To get new CDs I would need to travel to Cagayan De Oro City, a long way as I live on a small island in the Pacific. Is there anyway I can remove the write protection to format and use the CD? Thanks.