Touchpad Not Working in Zorin OS 16 on Lenovo Laptop

I'm running Zorin OS 16 with kernel version 5.13 on a Lenovo IdeaPad Flex 14ARE05.

My touchpad only seems to be detected by the system randomly. Most of the time it is not detected at all. But when it is detected, it is only when the laptop's battery has been fully drained and immediately booted after plugging in to AC power.

I have tried all the suggestions in this thread but haven't had success. Since that thread was for Zorin OS 15, I was wondering if there were any fixes for Zorin 16.

Thank you for your help.

This sounds a lot like the power manager is inhibiting the touchpad.
Can you please test this by running:

sudo -i

echo 'on' > '/sys/bus/i2c/devices/i2c-0/device/power/control'

I ran the test and nothing seemed to happen. Was echo supposed to respond with something?

No, the touchpad should, though.

OK. I do appreciate the help. Unfortunately the touchpad is still unresponsive.

So, maybe it is not the power manager...
Let's try driver:

sudo apt update && sudo apt install xserver-xorg-input-synaptics

Reboot and test...


I did run the command and rebooted the laptop, but unfortunately it still isn't working.

sudo nano /etc/modprobe.d/psmouse.conf

Add this line:

options psmouse synaptics_intertouch=1

Tap ctrl+x to exit, then the y key, then enter to save and exit. The terminal will revert to normal. Run:

sudo modprobe -r psmouse && sudo modprobe psmouse

Thank you for that! I've given that a try, but the touchpad still doesn't work.

Honestly... I am stumped at this point. Perhaps better users than me can step in more helpfully...
I will turn to running net searches and see if I can find anything.

Please remember that while your primary focus is on one thread, mine is on a great many threads as well as other facets of life. Feel free to bump the thread and remind us all of your plight if a reply takes too long.

Websearch of "Lenovo IdeaPad Flex 14ARE05 touchpad Ubuntu 20.04"
found this:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.