Trying Zorin on old macbook pro : wifi issue

Hi!
I'm trying Zorin on an old macbook pro 5.5. It seems promissing, but so far I haven't been able to use wifi.
I tried installing drivers for the broadcom wifi card from the installation flash drive, but I get the following error:


Any thoughts?

Do you have the option to use the phone as hotspot? If so install synaptic

sudo apt install synaptic

Open synaptic --> Edit --> Fix broken package

Translated from French, I get an error message that says : "No version of the synaptic package is available, but it exists in the database. This generally means it's missing, has become obsolete, or that it's only available from another source". E: the "synaptic" package has no version that can be installed

I just did a websearch for that Broadcom device and found this extensive item:

Please ensure that in Software & Updates > "Download from" you are set to Main Server. Before proceeding, please run sudo apt update && sudo apt upgrade , then follow the suggestions made above.

1 Like

Thanks for your suggestion. Now something weird happens when I try to follow your solution : the system flashes the password prompt, that "shakes" without letting me any time to type a password. Same thing when I try to use a proprietary driver, except that I get an incorrect password error message in the end, which I don't get when trying to change the update source. I tried rebooting, but it does the same.
Even more annoyingly, my system froze completely while I was typing this message... I had to reboot using the start button, and this happened twice, so I'm now writing from a different computer.

I would actually consider a fresh install given what you describe. The security of your system sounds questionable.

This was a fresh install. I tried updating the system, from the French repos, since I could not change them, and then the machine froze again. After a reboot, the screen backlight was set to max, impossible to modify via keyboard or GUI. So, in a nutshell, I'd say I love the look of this OS, but it's not working properly on my machine, so I'll find another one. Thank you very much for taking some of your time for trying to help me.

I posted a solution for another macbook pro user - the solution posted by a macbook pro user on askubuntu: