UEFI CSM boot problem

Referencing Cannot boot from USB - sole edit added by moderator

I’m having the same problem with my Toshiba Satellite C50-A and I can confirm the issue (in my case) is the UEFI. My Win7(64) is CSM, so if I switch the BIOS to UEFI, Zorin will boot but Windows will not. If I switch back to CSM, Windows will boot but Zorin will not.

Someone else I found only needed to reset his BIOS. If you haven’t already ruled it out, it’s worth a try: https://superuser.com/questions/1432795/usb-not-booting-and-bios-correctly-set

It is progress to have narrowed down the problem this far, but I’m not sure changing the BIOS every time I decide to switch OS is really workable in the long-term.

I also found this - https://www.plop.at/en/bootmanagers.html - but I can’t tell from the information given whether it will work for what I’m doing.

Everything I’m finding indicates that changing Windows to UEFI requires wiping the drive, which defeats my purpose in using a USB bootable drive in the first place. Is there a way to switch Zorin to CSM on the USB?

I may be missing something but why can’t you disable UEFI and then re-install Zorin?

I may be unclear, sorry. I used unetbootin to create a USB bootable drive with Zorin ( https://zorinos.com/help/install-zorin-os/ said to use BalenaEtcher, but I wanted persistence so BalenaEtcher referred me to unetbootin instead) and I was under the impression that this is set in the ISO? I’m after portability, primarily.

Unetbootin is a good choice. That is also what I use.
I have installed Zorin with UEFI disabled. If your Win 7 likes UEFI disabled, then just disable it in BIOS and reinstall Zorin. I was asking if there is a reason that wouldn’t work - as in, you may have tried it or I may be missing some other fact.

1 Like

I’ll admit I’m a little confused. We may be talking past each other. I’m not installing to the hard drive, just the USB, and the USB won’t boot unless I switch to UEFI, which breaks Windows. I hadn’t even heard of UEFI when I created the USB, so the laptop was still set for CSM at that time.

I haven’t found any indication that CSM vs UEFI is a setting in unetbootin, so I have no idea where to change that. I did find one thread at their Github that implies it’s set in the original ISO, which is why I thought that was where it had to be handled:

Am I making sense? I hope?

Essentially, you would need to reinstall Win7 set up for UEFI, which I suspect you would prefer to avoid?
OR, if you can reinstall Zorin not as UEFI as Carmar suggests, on the Persistent USB?

That is what I’m trying to figure out how to do, yes. Please.

I do not know how either at the moment and am currently tied up in something else- that was more to see if we can all get on the same page. :wink: But let’s research it.

Ok. Now I get it. I was confused because in my own experience it has been the opposite. I have had to turn off UEFI to allow booting from a USB. Sorry, that took me a little while to grasp.

Please review this link- you will need to scroll down a bit:

I had to redo this post since I accidentally replied to me, instead of you.

On the same page is good, yes. If it helps, I can go through everything I’ve done just to give history:

I downloaded Core from Zorin’s downloads page on zorinos.com and went to BalenaEtcher based on the Basic Install instructions. BalenaEtcher has an FAQ that mentions Persistence and refers users to unetbootin instead.

Unetbootin was a pain, refusing to see my USB drive. They have an FAQ that says to use the command line if that happens, but that certainly isn’t helpful to non-coders like me. I need the steps. It took a long time to get enough help out of my brother to be able to get the command line to make unetbootin come up with my USB drive, but it did work. The “burn” took a long time (pretty sure it was more than a couple hours), but it finished successfully.

When I couldn’t get it to boot, I had my brother try it to see if it had even created a bootable drive, and he said it booted into Zorin just fine. I tried changing boot order, I tried enabling power to the USB ports during sleep, I tried different ports - and finally I found the UEFI issue. Changing to UEFI made the USB boot up Zorin just fine, but then Windows wouldn’t boot. Until this point, I’d never heard of UEFI, and it certainly didn’t show up in the settings in unetbootin.

Pretty much all the results I find in search are focused the opposite direction, telling people how to switch to UEFI. I did find one link that claims it’s possible to convert Win7(64) to UEFI without wiping the drive, but his instructions make no sense to me. I’m not sure if he put in negatives where he didn’t mean to have them, but I never did find the directions to fix Win7(64) in spite of his headline: https://chrunos.com/convert-legacy-to-uefi/

The link I posted previously about resetting his BIOS links back to https://nmilosev.svbtle.com/booting-uefi-usb-stick-on-a-toshiba-laptop-insydeh20-bios which dismisses CSM and implies that the only thing that makes a USB drive UEFI is having an EFI folder. Opening the bootable USB in Windows File Explorer shows that there is an EFI folder, though I doubt it’s as easy as deleting the EFI folder to make it switch to CSM.

Sorry I’m slow, but I wanted to offer complete information.

Hmm. Looks like the primary difference here is the USB creator. I’ll try the Universal and see if that works better than unetbootin. It doesn’t look like they have any settings for CSM vs UEFI either, but if it isn’t UEFI compatible, it should work. Given how long it took to create the USB before, it’ll take me a day or two to get it finished and tried out, because of work. I will definitely report back. Thank you!

It can be frustrating. Part of that frustration leans heavily on the “never done this before” action. It’s like assembling an IKEA desk.
The first time you do it, you are hating the Universe. The third time you do it, it takes five minutes.
In this sense, it is not in the Burner that you find the setting but in the Ubiquity installer that installs Zorin OS on the drive.
Please navigate to the webpage link I posted above that you just referenced and hit ctrl+f on the webpage to open the Search Function of the page.
Enter in:

Legacy BIOS: Following shows for /boot partition

There is an image of an Ubuntu Installer showing the same thing. To reach this, select “Something Else” from the Installer screen that says “Install Zorin alongside…” Or “Install Zorin (wipe drive)…” Below this is: “Something Else”
Choose Something Else and it will open GParted partition Manager.
Fuller instructions are on the link provided above, but in the image we just moved to with the search on the webpage above, we see a dropdown menu:

Use as: Ext4 journaling file system


Followed by the mount point drop down menu below it. While not clearly labeled as such, this is the setting you need for Zorin.

Hopefully, this will work.

I may be misunderstanding, but it looks to me like this is about installing on the HDD, not the USB. I was only intending to stick with the USB, going as portable as possible.

That said, the Universal USB Installer from that article you linked did what I needed. (just to rule it out, I tried deleting the EFI folder and confirmed that it doesn’t work that way) I’m having a couple video glitches at startup and shutdown that are probably a driver issue, but it’s literally only at the transition (I guess it doesn’t like the animated version of the Zorin logo) and then it runs Zorin just fine, as far as I can tell so far.

Thank you!

You can change this by booting up on the USB, then opening a terminal
and entering in

sudo update-alternatives --config default.plymouth

Choose the Zorin Text theme instead of the Zorin Logo theme.

Then update it to load the new settings

sudo update-initramfs -u