USB not accessible after flashing zorin

Hello,

Why I can't create a USB boot drive for zorin but was able to create one for mint and one for Ubuntu?

Using Windows 10, I was able to create a boot disk and boot Linux mint, but decided not to install because I discovered Ubuntu.

So then I created a Ubuntu boot disk in windows 10 using the same USB stick, and was able to boot and install Ubuntu.

Then I discovered Zorin but am unable to create bootable USB to install this OS.

I have created bootable USB with balena etcher and rufus to install mint and Ubuntu.

Now that I am trying to do the same for Zorin, I can't boot after flashing nor does the USB visible in the file manager when I plug it in the USB slot.

I tried formating these USB sticks in Microsoft windows with no success. Then I decided to try formatting in Linux. 2 out of 3 sticks was recovered and shows up in the file manager for both Ubuntu and Windows.

Now that the USB sticks are accessible I then decided to use Ubuntu to create the boot stick for Zorin, but Zorin is still not booting.

So I then decided to try formatting the USB stick again in Linux, to re-try the process from the beginning, except that the sticks are now not accessible in Ubuntu too.

Does anyone know what I am doing wrong? I was able to create boot drives twice(once with etcher, and once with ruphus, but can't get ruphus nor etcher to create the boot disk again.

@whitecloud Hi and welcome to the Forum.
Have a look at this thread which contains a useful checklist of things to do for a install.

Pay attention to #1 i.e. verify your dowloaded ZorinOS file checksum is correct.
I always use Unetbootin to create my bootable USB, which has never let me down, but is personal preference.
When you formatted the USB's did you do a full format, not quick format. Also what filesystem did you format them, FAT32?

1 Like

Thanks for replying to my question.

I verified the Zorin prior to you mentioning it, but I did it with rufus. It shouldn't matter this way as long as the information matched, right?

What I don't understand is how I successfully created boot drives twice. In addition, after you mention bit locker, I decided to use the boot drive creator in Ubuntu on a new flash drive. Same problem. It did not boot. I also used the windows laptop to see if the drive will show up in the explorer window, and it didn't.

This means I can no longer create boot drives with 3 different programs, in 2 different operating systems which are on 2 different laptops.

I would be inclined to think I did something wrong in the BIOS that is causing the boot process to skip booting from the USB, but these flash drives are not accessible in the explorer windows after the flashing process too.

I will try the unetbootin and disabling bit locker in Microsoft windows, but the boot drive is not booting when created in Ubuntu either.

If you or anyone else have any additional clarification, please let me know.

Thanks

I do not agree. Honestly, everything you have described so far suggests something else that is neither your fault, nor within your control.
How old are these flash drives and how much use have they seen? (Barely ever used... heavy use? Constant use?)

First I was using older flash drives so I figured the age of the flash drives might be the problem so I bought 2 new ones 2 days ago just for this task and they are both not booting too, and at the moment not accessible in windows explorer.

If I were at least able to reuse these flash drives to try making boot drives for linux mint and ubuntu to retrace my steps, then I might be able to figure if I am the problem( like maybe since I am not a pro I might be forgetting a step, etc)

So far I was able to learn how to delete partitions and format the flash drive in Ubuntu, however, the newly formated drive formated in ubuntu is still not showing up in microsoft windows explorer.

When I get home I will try diskpart in windows to clean and format to see if that makes it accessible in windows again.

Thanks for considering my dilemma. If you have any ideas that might be able to help, please let me know.

And you did ensure that Fast Boot is disabled in Windows and the EFI setting for Secure Boot is disabled, as well?
Do you have any current installed Linux OS?

Yes to all of your questions. Currently I have Ubuntu on 1 laptop and trying to install Zorin on the same laptop.

I tried diskpart with no success in windows.

The disk is detected by diskpart but not in explorer.

The diskpart commands works to list, select and create partitions but when it's time to format, it says access denied.

So I am assuming that whatever is denying access is also causing the drive not boot zorin os.

If this info provides any clues to a solution please let me know.

I think this is helpful, as it suggests that an installation and a boot can be successfully done. It also allows access to a Linux OS to work on with the guides at the bottom of this post.
While Zorin does have some key differences from Ubuntu - in otherwords, you cannot say Zorin is Ubuntu, just reskinned - In these regards it is similar enough to Ubuntu as far as the Ubiquity installer, Casper and the underlying mechanics. If Ubuntu is working and installable, There is No Reason that Zorin cannot be. Not by the Windows Machine, not by Zorin and not by the presence of an existing Ubuntu.

I am not a Computer programmer, I am an automechanic. Classic cars. Some years back, I did a lot of work on someones old car. He was experiencing loss of power in his number two cylinder. Logically, he replaced all the spark plugs. Problem remained. I did some tests and could find nothing wrong. Even so, I opted to replace all the plugs. Problem remained - misfire and power loss in number two cylinder.
I ended up replacing his head gaskets, valves, timing chain, Valve cover gasket (as well as fluids and peripherals) for free chasing down the problem only to finally try... Changing the Number Two Spark Plug again.
That was it.
What are the odds?! This poor guy hit the lottery getting a Faulty Plug three times in a row. And it landed in the same Cylinder, even*... One of those times, it was me that replaced the plugs and - it happened to be faulty, too.
shrug Life. It gets weird.
I kept discounting the possibility of the plug - for you know... obvious reasons...

  1. USB drives can be fickle little things. Some companies - I Kid You Not - even fake them. They take a cheaper 16gig board, then put a bit of programming on it to make it read like a 32gig. Then sell it as 32 gigs for a higher price. This actually happens a lot. But the space is still limited by reality... and sometimes a person finds out when having more than the drive can hold causes strange and hard to figure out problems.

  2. This one is uglier and I may be about to lose some popularity points in saying this outright but... There is an open question as to whether or not burning a bootable OS on a USB actually damages USB drives. I have never had it happen to me, but on this forum in the last couple years, I have seen many people complain of it or start threads asking for help trying to figure out what happened - only to find their new USB drive was shot. Some were able to reformat the drive and recover it and use it again, some were not; they trashed the drive and bought new either from lack of success or lack of effort.
    It is known that if a severe enough interruption happens during write on a USB drive, it can corrupt the drive or render it inoperable. Some of these folks saw no interruptions at all. Nothing they could notice. The majority of the complainers say they used BalenaEtcher.

Moving toward finding Solutions:
First... Like those spark plugs... You may just check the USB drives. You may try checking your USB ports, clearing them of any moisture or dust- or switching ports. Do not use a USB hub ever (For creating bootable mediums or for installing an OS), as that is always iffy.
Next, here are a series of hopefully helpful guides that you can follow the steps on to see if any of them help.

https://answers.microsoft.com/en-us/windows/forum/all/windows-10-does-not-see-usb-flash-drive-but-linux/d237c0bb-8f9b-438e-bfb6-a2c999734696

For some projects I was working on (personal programming) I needed to have a later version of gtk and some other stuff, including latest Gimp and Blender. While awaiting Zorin 16, I installed Ubuntu 20.04 and Ubuntu 21.04 (Dev).
When Zorin 16 TESTING was available, I loaded it up and the speed and performance blew 20.04 and 21.04 away.
It's worth the extra effort.

Also are the USB's USB3 or USB2 devices?
Like @Aravisian has said, USB sticks can be fickle. Try a different port to format again.
(i.e. move the spark plug to a different cylinder and see if the fault moves)

I've experienced a similar thing. You mentioned you used Etcher on the drive once before. Etcher has a habit of destroying the USB, but it should be recoverable. However my first question is, does your USB drive have a LED and does it light up when you plug your USB in your computer?
I recommend you to read through this article by Balena themselves and follow their steps (Preferably in windows). As long as your USB drive is not physically damaged, I believe it can be recovered.
I assume you used Rufus at first, then you used Balena Etcher. I'm gonna blame Etcher for what has happened to your USB, since this is not the first time I've seen this happen.

Thanks for the replies. Lots of information. This is definitely a great troubleshooting lesson for me.

I have perfectly good access to flash drives on both laptops on all ports 24/7.

However my first question is, does your USB drive have a LED and does it light up when you plug your USB in your computer?

Yes.

FAT32 full format. When I bought the new flash drives I deliberately bought 3.0 because the windows laptop USB ports are 3.0. I checked it in the device manager I believe.

I tried the dd command in linux, and diskpart and format commands in Windows power shell. Both says access denied. Some commands do work but in the final step in the instructions, I received the access denied message from both linux and windows. Images of both are below.

image

With this, I decided to buy four 2.0 flash drives to try flashing again. I choose to buy 2.0 drives because my first 2 successful boot drives(mint and ubuntu) were created on the older flash drives(which I am assuming are 2.0 drives) prior to them becoming unusable.

The reason for my assumption that the older flash drives were 2.0 was based on observing the speed when creating the boot drive on the newly bought 3.0. The flash speed was faster on the 3.0 drives so I deduced that the older drives must have been 2.0 drives. Does my thinking on this make sense?

Before I start flashing again I thought I should describe my previous flash events. It might help you to help me:

My first successful flash was done by Etcher when I made a boot drive of Mint. I didn't install mint because I was still distro searching. This mint boot drive booted several times, except I didn't install it. My second successful flash was done by rufus when I found ubuntu, and I immediately did a full installation on the laptop.

My First failed flash occurred when I used Etcher to create a Zorin boot drive, and I think I used Etcher again when I used the second flash drive to try flashing again. These were the older flash drives I owned for a while. This was when difficulty accessing the flash drives began.

My second failure occurred the first time I tried ubuntu boot disk utility to create a Zorin boot drive. This flash was done using the newly bought 3.0 drives.

So now, I am thinking my next attempt on the new 2.0 drives should be on rufus. This is because I never experienced a failure with rufus, even though I only used it once.

I read in one of the links above that I should turn off bitlocker, so I intend to do this before this flash attempt.

Does anyone have any recommendations I should try before I try flashing again with rufus? I intend to try unetbootin and others.

Again, thanks for your much needed guidance.

1 Like

Perhaps this may provide helpful details:

It does; it is a reasonable conclusion. I am not too sure that the drive being 2.0 or 3.0 should show much difference other than write speed.

I only use Unetbootin and have never had any trouble. Have never used Rufus, as I no longer use Windows at all.

1 Like

I decided to use the Unetbootin, the windows version, just because I am not yet familiar with linux to use the linux version.

The Zorin finally booted and I was able to install it perfectly in one shot on the laptop.

The USB drive still works too. I decided to flash Zorin to it twice just to see if it will disappear from the file managers. It did not. It's still there and still usable.

This is a big relief because I really like what I have been learning about the linux and would like to rid myself of Windows.

Thanks a million.

1 Like

Etcher has been known to create unusable thumb drives more commonly than its ability to create bootable thumb drives. I have used rufus for all of my installations (windows and Linux) and only ever received an unusable error when the drive finally failed (years later). Your best bet is to stay away from etcher. Unetbootin and rufus have been the most reliable according to multiple users of the forum, for future reference.

1 Like

Thanks. I will delete etcher.

My install method is probably unsuitable for most folks, despite the machine being relatively new.

When my old Compaq rig died around 18 months ago, I'd just fitted a brand new tray-loader optical drive (it had always had dual optical bays). I wasn't chucking this away, so my new HP desktop had an optical drive anyway, plus I obtained a USB 3.0-to-SATA adapter lead to run the old one, too. I prefer the old one anyway, since the new HP drive is a cheap'n'nasty laptop-style one.....eurrrgh!

I burnt the ISO to DVD. Ran it 'Live', then did a 'something else' install to a ready-formatted 32GB SanDisk USB 3.2 Ultra 'Fit' thumb-drive.....allowing it to install GRUB2 to that drive.

I normally run 'Puppy' Linux, which uses Grub4DOS.....a heavily 'patched', updated version of the old legacy GRUB. The 'Advanced' menu for this lets me boot straight into the thumb drive....

Like I said, probably not the way most here would need to tackle it. Though I couldn't agree more about Etcher; 337harvey is absolutely right in that respect. For direct installs to a thumb drive, UNetbootin has never let ME down, either.

Mike. :wink: