Video has a line when fast images and scrolling is bumpy

Hi, so I am totally new here and very happy with this new linux experience so far apart from the fact that my xps 13 7390 2in1 isn't supported. Meaning finger print doesn't work, or at least I haven't figured out how and sliding my fingers back in a browser doesn't go back a page. I can live without that, even though it would be nice if this was fixed. But my main issue is that when I watch a video and the images moves fast I get a break in the video. Like a line that splits it in half. I found this video on the topic but that didn't work. How to Fix Intel Graphics Horizontal Lines Tearing Bug in Debian, Linux Mint and Ubuntu - YouTube Although I am assuming it is something similar.
I also noticed that when I scroll the youtube page it isn't a smooth scroll. It has little hick ups. Seems to be on other page with video content too. Any help would be much appreciated.

Can you please open a terminal with the keyboard shortcut ctrl+alt+t or from the App Menu.
In the open terminal, please paste the command:

sudo lshw -C video

Copy and paste the output here. This way we can take a look at the drivers in use.

The output of

xrandr

may also be useful for checking your Refresh Rate.

Okay, So most of the fingerprint hardware isn't compatible with any Linux, So don't bother about that. Can you please tell me your video driver (NVIDIA / AMD), Cause it looks like a graphic problem.

Good Morning,
thank you for helping me here.

hdky@hdky-XPS-13-7390-2-in-1:~$ sudo lshw -C video
[sudo] password for hdky:
*-display
description: VGA compatible controller
product: Iris Plus Graphics G7
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 07
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=1920x1200 visual=truecolor xres=1920 yres=1200
resources: iomemory:600-5ff iomemory:400-3ff irq:173 memory:603d000000-603dffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff
hdky@hdky-XPS-13-7390-2-in-1:~$ ^C

then I ran the other command:
hdky@hdky-XPS-13-7390-2-in-1:~$ xrandr
Screen 0: minimum 320 x 200, current 2560 x 1600, maximum 16384 x 16384
eDP-1 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 288mm x 180mm
1920x1200 59.95 + 59.88 47.96*
1920x1080 60.01 59.97 59.96 59.93
1600x1200 60.00
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 60.02
1440x900 59.89
1400x900 59.96 59.88
1280x960 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1360x768 59.80 59.96
1280x800 59.99 59.97 59.81 59.91
1152x864 60.00
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
800x512 60.17
700x525 59.98
800x450 59.95 59.82
640x512 60.02
720x450 59.89
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
680x384 59.80 59.96
640x400 59.88 59.98
576x432 60.06
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
hdky@hdky-XPS-13-7390-2-in-1:~$
hdky@hdky-XPS-13-7390-2-in-1:~$

Yeah I figured that and it didnt even work well on windows. So I am not too worried about that. If I check for additional drivers under software & updates nothing shows up. This is what I found under the about tab: Mesa Intel® Iris(R) Plus Graphics (ICL GT2)

Hope that helps.

Notebook computer, 60hz... Pretty normal.
It looks like you are not using a Nvidia card.

Can you please add the grub parameter i915.enable_psr=0 and see if that helps resolve the issue:

sudo nano /etc/default/grub

Look for the line that looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Place the above parameter so that it looks exactly like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0"

Tap ctrl+x to exit the document editor, then the y key to say Yes to save, then the enter key to save the current configuration.
The terminal will revert to normal.
Now you must run

sudo update-grub

in order for the changes to take effect.
Reboot and test...

Hi,

I did all of the above and it seems better but it isn't completely gone. I don't notice the strange split when I am scrolling video pages like youtube anymore but I am still noticing a little break watching a video.

I am using brave and have a VPN running, if that makes any difference.

You also could try:
i915.modeset=1
or
i915.enable_dc=0
and see if you get better results. If you run into trouble, tap the esc key starting at the motherboard splash screen to pull up the Grub Menu. Select Advanced Options for Zorin > Recovery
Arrow key to the last option to Drop To Prompt and use

sudo nano /etc/default/grub

to revert the changes if needed to restore access and functionality. Be sure to remember after each change to run

sudo update-grub

for the changes to take effect.

Ok, so I tried all three options but none of them have solved the problem completely. I feel that the first option did the best job but it wasn't 100%.

Q: what is the motherboard splash screen?

Any other ideas of what I can do?

Hi,
I just pressed the ESC key when booting my laptop and all I see is grub. Grub grub no commands that I can press?

I tried putting in the advanced command but it just returned can't find command