VirtualBox uninstall problem

I am afraid you got a cause and effect wrong.
The cause of the problem is secure boot which manifests itself as a problem in VirtualBox update.

Even we could help you to solve the current VirtualBox issue, you will hit another roadblock eventually when such update comes to your system next time.

1 Like

I haven't read it as it doesn't solve my immediate problem.

1 Like

Try this? sudo apt-get --fix-broken install

OP can try.
But I do not think it would help.
I first thought the problem was incomplete installation but then I found out that the system got secure boot enabled.

1 Like

I find it hard to make any sense of that though because I have been updating my Zorin 16 Pro system everyday since 17th August and everything has been fine.....with UEFI Secure Boot enabled.....up to now and this VirtualBox update.

So if I remove the VirtualBox update my immediate problem is

1 Like

9 posts were split to a new topic: Security in Windows and Linux

You need to configure your packages. Something has corrupted or broken.

1 Like

So um I can no longer like for the day lmao. i also made maximum number of edits

can't edit anything, ouh nevermind I can edit, I just made maximum edits for one particular post I think?

You should learn how to consolidate your postings into one. It is not a Twitter and longer meaningful postings are more appreciated than short meaningless ones.

1 Like

Happy to receive anyone's help and appreciate it too. Not happy to turn off UEFI Secure Boot on a dual boot system with Win 10.

Neither Win 10 nor UEFI Secure Boot have cause the issue, it's the update to VirtualBox from what I can tell and I just need to remove it.

I can promise you I'm not trying to annoy anyone, it would be counterproductive especially as I intend to be a committed Zorin user and will likely be asking for further guidance in the coming months. You especially Aravisian helped me a couple of weeks ago with the Dell problem.

Thats what I do, I keep editing the post to add information. @Aravisian told me about it.

Kedric, I'll try that but is it OK for me to kill off the Terminal which still has the process running from before? It's waiting for me to say OK to this:

Lucky you.
Now you got 2 mentors on this forum :slight_smile:

Should be ok, you're not installing or deleting anything.

I understand your point of view. However, the trouble is that you also refuse to configure it. Do you see the issue here? You won't turn it off, but refuse to configure it, creating your own quandary.

This is what we are trying to explain: The virtualbox issue is a symptom not a cause.

Mate, thank you, I'm definitely on the same page about being careful, hence my reason for posting and asking for help. The enrolling an MOK worried me because I don't know the implications and it's also a third party driver and all a bit above my head.

Anyway, I appreciate your post and good luck Wisconsin :slight_smile:

In which case, you can just close the window as Tom suggested. This will bring us back to the original problem.
First, you need to be able to successfully run dpkg --configure .

Well I ran sudo dpkg --configure -a and that message is where it is now sat. OK, I'll kill the terminal and try that command you gave.

Did that, killed the terminal, tried the command Kedric gave sudo apt-get --fix-broken install and am now back at this again:

It's a bit of a loop and there is no way to say 'Not OK' and I certainly don't want to create a private MOK, especially for something which I'm actually trying to uninstall.

1 Like