Weird graphical glitches

Hello,first of all, want to say that ZORIN os was my turning point,i love it and i am not going to use windows again.Everything works just fine except from the graphics.There are some weird glitches with the screen.The most common is that the screen goes black for a fraction of second and back to normal again.This is happening VERY often and it is really annoyng.I tried to reinstall the nvdia drivers but nothing changed,i downloaded all the drivers that you can see in the screenshot.

only the last option seems to work fine but i got very low fps when playing games with this.

here is my specs:
11th Gen Intel® Core™ i7-11800H @ 2.30GHz × 16
NVIDIA Corporation / GeForce RTX 3050 Ti Laptop GPU/PCIe/SSE2
also i have to mention that i am new to linux
Thank you! and sorry for my english :confused:

Assuming the 495 driver also gives you problems, try: [How-To] Install the latest Nvidia driver on Zorin OS 16 & Pop! OS 21.04


Don't use an Nvidia driver that has TESTED in the name, contrary to logical way of thinking, they tend to be less tested then they claim to be, and more of a mess then anything else. I personally have had nothing but trouble with the tested drivers.

You only want to use a Nvidia driver that has just PROPRIETARY in the name, those are the good ones, regardless of which version you use. I personally have an RTX 3080, and I am using the 495 driver.

1 Like

it seems a bit complicated but i will try it as soon as posible,thank you!

Oh i see,so i have to avoid TESTED and prefer the latest right?Thank you for the tip! Although i already tried with the 495 driver ill try again

1 Like

it did not work

Please inform everyone what kernel you are using...

CTRL ALT T to enter terminal.

uname -a

Please post results here....

1 Like

give me five minutes and i will upload a screenshot

I followed the instructions carefully but at the step 8,after the reboot my laptop froze.I entered in safe mod but there was just an empty black screen with nothing.Im correctly reinstall the OS, after that i will upload in a screenshot the kernel version

I found this post,this might help me.The only problem now is how downgrade my kernel back to 5.11

Hold shift or F2 while booting computer up, to get GRUB menu. Then select an older kernel from the list.

Good Luck

1 Like

I managed to downgrade kerner 5.11 but this did not fixed anything at all.It might did things worse.The glitches are more often now especially when a task is performed via terminal (downloading discord for example)

Please open a terminal and run

sudo ubuntu-drivers autoinstall

I did that a couple of times,it did not worked either

You have tried multiple drivers and you have tried a different kernel...
Have you tried the nomodeset grub parameter?

sudo nano /etc/default/grub

Change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Reboot and test

after the reboot the screen froze to the computers logo and it can't boot.I performed a format in order to get it back to work

Something irrelevant i just found.I did not had to perform a installation,i could just edit the grub in the grub screen,good to know for the next time

and...can you post me the "display" or "monitor" section of settings app?

Here you go the laptop is ASUS TUF GAMING F15