Wifi not working after update - need kernel update

Referencing WiFi is not showing | No WiFi adapter found error in Zorin - sole edit added by moderator

I have a similar problem where my wifi stopped working under Zorin OS (but is fine on the same laptop using Win10). This happened after an update in the last two months, and when I installed Zorin on my mothers laptop a week ago, having selected “Install all updates”, the wifi never got working.

The error is the same in both cases, with wifi being enabled, but saying “Wifi not available” in the header of the settings tab, and showing an empty list of networks. My laptop is the Huawei Matebook D14, my mothers the very similar Honor Magicbook 15.

Since I have found hints that an updated linux kernel solved the problem, I was wondering if there is any way that I could update parts of Zorin manually. Most manuals say that you need a linux with an internet connection, but with my error I can only download files from windows computers. Are there any update packages I could download and install on linux via a USB drive?

Any help would be appreciated.

In order to install the updates, please connect to the Internet temporarily by plugging in an Ethernet cable or Wifi dongle.

If you don’t have a USB Wi-Fi dongle and your computer doesn’t have an Ethernet port, you can plug your iPhone or Android smartphone into your computer to use it like a Wi-Fi dongle:

  • On Android. Open the Settings app on your phone and navigate to “Wireless & networks,” tap More > Tethering & portable hotspot and enable “USB tethering”.
  • On iPhone. Please make sure that the USB Tethering setting has been enabled in the Settings app.

After plugging in the phone with a USB cable, it should connect your computer to the Internet.

If you have a limited mobile data plan, please make sure to disable 4G data before downloading the updates, as downloading the required files will take a few hundred MBs of data.

Hello @Collindo! Are 2.4 GHz and 5GHz turned on in the Wifi router settings? If one is not turned on, it can also be the source of the error.

Both are turned on, but I would be interested in knowing why this would be an issue for linux, if only one frequency band is available?

Thanks, @AZorin, I will try to get my hands on a wifi dongle or use my smart phone.
The laptops of course nowadays do not have Ethernet anymore sigh

2 Likes

That depends on manufacrturer - Asus ship USB/Ethernet Adapters. :wink:

Some devices cannot use the 5GHz frequency.

Now you’re just trying to make me jealous :smile:

Don’t be jealous!:

1 Like

Really makes you wonder, doesn’t it? What are they thinking?

You may also try using your Zorin Install disk to achive some function:

Also, you may scroll down to the other terminal commands.


If problem appeared after an update, you may check if it is something really simple like regdomain:

sudo -H gedit /etc/default/crda

REGDOMAIN=
(That is, blank) will work or you may have to have your country code.
REGDOMAIN=FCC
for United States
REGDOMAIN=GB
for Great Britain…
After changing your regdomain, you must reboot to see the effect.

Ok, so I tried everything mentioned so far, with negative results.

  • Changed REGDOMAIN to DE for Germany and rebooted - no change
  • Tried to mount a Ubuntu-iso and let it be searched for drivers - CD kept unmounting as soon as it was being searched
  • Tethered an internet connection and got updates incl. the Zorin kernel - no change

What I noticed when I typed lshw -C network in the terminal was that it says *-network DEACTIVATED in the first line. That is probably the issue, but I would need to know how to change that…

Try

sudo ifconfig wlan0 up

(or run iwconfig in terminal first to grab your interface name if different)

I already figured out that my wifi is called wlp2s0, but if I use ifconfig, it says the command is unknown…

Guessing that means that

sudo ifconfig wlp2s0 up

did you no favors?

Check if under
/etc/modprobe.d
your controller is blacklisted.

When I type that in, it says “command unknown”.

There is nothing there that resembles realtek or wifi, so I guess it’s not blacklisted.

Dear Colindo,

I regret to inform you that I hate your computer.
Sincerely,
Aravisian

1 Like

Being new to Zorin and linux, I was wondering if there is a way to rollback the update that I made. I believe if I go back to mint Zorin 15.2, I would have my wifi back again…

What kernel are you running, now?

uname -a

It’s 15.3 now, not sure if that was since today or the earlier update a few weeks ago.

Edit: Sorry, the linux kernel is 5.4.0-42-generic.

Ok, same kernel as me. I wonder if you need to rollback your kernel to the previous version.

https://forums.linuxmint.com/viewtopic.php?t=295894

As you can see in the thread above… Yes, you may get wifi back if you install Mint, now. But you could run into the same trouble later on Mint, too.
With every distro, you really run the same risks of updates with hardware compatibility. It’s up to us to help each other through them, on distros and on forums.

The above thread I just linked to also discusses changing the kernel and the firmware.