Win type desktop shortcuts & URL icons

Running Zorin 16.
Trying to move my wife from W 11 to Zorin.
Challenge - can I add Win type desktop shortcuts to web URL etc and display them as icons on Zorin desktop.
She is not able to use keyboard shortcuts.
Any help appreciated

Does TabNumlock's tutorial solve your issue?

You mean like having a desktop icon that launches a specific URL? I prefer doing it the way that ZorinOS itself creates their "Send Feedback" shortcut, and create a custom .desktop file.

Create a new file named <name_of_website>.desktop and place it under /usr/share/applications, with the following contents:

[Desktop Entry]
Exec=xdg-open <url>

For example to launch this forum:

[Desktop Entry]
Name=ZorinOS Forum
Comment=Direct access to the ZorinOS Community

Now, you can not only have it on the desktop but also on the main menu, taskbar and even search for it easily. For the icon, you'd probably want to download the site's favicon and save that somewhere in your computer that you can reference.

For an easy way to download favicons you can use this URL:<url>.ico

Replacing url with your actual url of course (note that it probably works best if you only use the base url, instead of some complicated session id or specific thread). For example, again for this forum:

Hi ZenZen.
Followed your instructions.

  1. Had to use KATE for text editor as could not save text into usr/share/a-pplications folder - permission problems.
  2. When attempting to open URL it reverts back to Kate or inbuilt text editor, not to Firefox.
  3. Will not link to icons
  4. Followed same instructions in Kubuntu with no problems - opened straight into browser.
    Any suggestions.

The permission issue is expected, given that anything under /usr requires root privileges. I think what happened here is that when you used Kate there was a file association made to continue using it for this file extension.

First, take a look at this thread to know how to navigate using the file explorer and be able to edit files that require privileges.

Then, navigate to the .desktop file you created. Right click -> Properties -> Open With -> Reset. This should remove any existing file associations for this extension and should launch shortcuts normally.

1 Like

Fun continues: on sudo nautilus get:

  • (org.gnome.Nautilus:10949): WARNING **: 21:14:22.811: Unable to get contents of the bookmarks file: Error opening file /root/.gtk-bookmarks: No such file or directory

** (org.gnome.Nautilus:10949): WARNING **: 21:14:22.811: Unable to get contents of the bookmarks file: Error opening file /root/.gtk-bookmarks: No such file or directory
Nautilus-Share-Message: 21:15:11.196: Called "net usershare info" but it failed: Failed to execute child process “net” (No such file or directory)


Those messages are normal when launching Nautilus from a terminal, not sure why though. However I just tried and turns out you don't actually need root privileges to access files under /usr/share/applications so that wasn't required, sorry about that.

While you are at it, double check the name and contents of the file. Especially things like spaces at the end of lines and things like that have a nasty habit of causing trouble sometimes.

If you launch Nautilus in Root, it cannot access the saved bookmarks that are in Home Directory, not Root directory. It is a harmless warning.

If you open the file using User Privileges and not Root, you will not be able to save any changes made. You can access the file, you can even make changes - but you cannot save those changes unless you elevate to Root.

You must elevate to root:

sudo -i


Then navigate to "other locations" > "Computer" > /usr/share/applications and edit the appropriate desktop file in the preferred text editor while elevated to Root.

1 Like

True that, although it seems that for resetting the file associations it works fine, since you are not modifying the file itself.

Oh, I thought you were modifying the file contents.

I wonder off and pretend to look busy.

Well I did suggest to check the file name and contents for any malformed setting, but only then edit it. The issue seems more related to the file association though.

I find that carrying a sheet of paper around always makes you look like you are going somewhere. Walk quickly and say you're late for a meeting if someone asks. Never fails!

My technique is a little different. If someone interrupts me, I usually stop and give them this subtle glare until their voice trails off and they look uncomfortable.
After a moment of silence, I quietly say

"Are you done?"

A nod.

I walk off as if having barely spared their life.

Works like a charm!


Hi, I have installed the anaconda suite and am trying to create a menu shortcut to open/run the base virtual environment that comes bundled with it and launch the navigator, through a .sh file I have created and let on the main folder. I have found this and tried following along, but it isn't even showing up on the menu. Rebooting didn't fix. Here's how I wrote it:

[Desktop Entry]
Name=anaconda navigator
Comment=launch sh
Exec=source ~/anaconda3/bin/activate && anaconda-navigator


Try the followeing, replacing $USER with your actual username.

Exec=bash -c "source /home/$USER/anaconda3/bin/activate base && /home/$USER//anaconda3/bin/anaconda-navigator"

Nice, this works, but it's on the 'Other' submenu, can I move it to 'Programming'?

Yes, add the line
You can modify the above as needed.

1 Like

I thank you plenty, it's just like I had it in mind

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.