Windows apps installation issues

Was able to access that path but no options.ini

Also,one app asks for a minimum of windows 7 Sp1 installed…how do I go about this?

Could you provide the output of wine --version? Could you also tell us what these applications are?

I looked this up, so I am not sure if it works. According to a variety of WineHQ threads,
Install

sudo apt install libgnutls-dev:i386

sudo apt-get install winbind

The next step for Wine was that they provide some support for Aero, as that is what the app is looking for, which the devs say has been fixed:
https://bugs.winehq.org/show_bug.cgi?id=39469

EDIT: Here are a couple more threads that are less scattered than the others and more direct:
https://www.playonlinux.com/en/topic-15643-Please_upgrade_to_Windows_7_with_Service_Pack_1_SOLVED.html

a) Navigate to Select the default wineprefix → Install a Windows DLL or component. Check riched20 and click OK.

b) Navigate to Select the default wineprefix → Install a Windows DLL or component. Check dotnet452 and click OK.

That seems a LOT simpler than some of the other stuff I read. One user said that they had to install winbd, gnutils 386, then Reinstall WINE. So that fix mentioned in the above WineHQ thread seems to be very effective.

2 Likes

I’m in wine 6.0 some of these program are ‘Dawn Of War’(Warhammer40k),Hypersonic 2 VST
Those give the Access Violation when trying to install
And a Studioone V3(which requires a minimum of windows 7 sp2 to open

The wine prefixes solution

Your Wine version is the latest. I’ve played DOW Soulstorm on this laptop, I’m guessing your machine is better than it. Can you see if there are any broken packages on Synaptic?
I use PlayOnLinux - which I recommend you to try out. It can also be installed using Synaptic. It’s just a front-end for Wine but it has gotten my games easily working when I was struggling with plain vanilla Wine.

For StudioOne, see if this helps: PreSonus Forums | Ubuntu Linux and Studio One | Studio One Forum Community Support

3 Likes

Can you please guid me on installing using synaptic? Also on ZORINOS,where is this illusive ‘game directory’(to solve the memory access violation)

libgnutls-dev:i386 has no installation candidate

Game directory: written in my very first post on this thread.
Synaptic: click the linked word “synaptic“ in my post just before this one - all instructions are on that link

Wine Version is currently 6.0 thanks tp @Aravisian
to date im still getting the 'This application requires Windows 7 SP1 with Platform Update or later

I did a search for “linux wine application requires Windows 7 SP1” and the first (and only relevant) result I found was:

https://forum.winehq.org/viewtopic.php?f=8&t=25260

That thread is almost 6 years old. The last post on that thread links to a bug report that if you click on that and scroll to the end, the bug was resolved in version 5.18.
Given all that, I hope you will consider posting your current problem at: Linux - WineHQ Forums
I am certain that if you tell them about this problem then they will find a resolution. Please give it a try.

1 Like

i got lost completely,can someone give me an easy step by step instruction? firstly this DWM thing they are on about doesnt exist no matter what i seem to install... please help

Here is what I did when I installed Soulstorm on PlayOnLinux:
a. If output of wine --version is NOT wine-6.0, then do steps 1 & 2 here: NET Framework 4.5.2 - #5 by carmar
b. Install playonlinux using Synaptic.
c. Steps on playonlinux are easy - all buttons & no terminal commands:
i. Click Install button
ii. Click Next 4 times
iii. Enter name of a virtual drive - make up a name
iv. Click Next 2 times
v. Choose either 32 bit or 64 bit - if after installation, the game doesn't work on 32 bit, then try 64 bit and reinstall and try again.
vi. Browse to game installation .exe file and click Ok. The .exe will run just like on Windows and MAKE NOTE OF THE INSTALLATION PATH.
vii. Wait for the .exe to finish running - just like on Windows. Make sure you have unchecked any options to run the game at the end of the install. Some GOG installers tend to have this option.
viii. After the installer is done, the system returns you to the PlayOnLinux menu which asks you if you want to create a shortcut. Select the Browse option (2nd option) on that list and browse to the game executable using Home -> PlayOnLinux's Virtual Drives -> Name you gave the Virtual Drive in step iii -> drive_c -> your game installation folder based on step vi.
ix. PlayOnLinux will create a shortcut on your desktop which you can then double-click to launch your game.

I don't know about anything outside of PlayOnLinux but the above directions are the easiest they'll ever be.

2 Likes

It seem really straight forward and my wine version thanks to @Aravisian is 6.0
So I'm gonna jump to step 'b.'

Playonlinux wasn't installed for some reason...installing it..

I still get the error 'Runtime Error (at -1:0):

And then I tried another anothe installation using 32bit option and I got 'Access violation at address 00000000'

What's weird is Studio One for example was working when I first installed ZorinOS light

DOW shouldn't give an access violation. If it does then reinstall Wine - POL is just a front-end, the problem lies with how Wine is installed. I've played Soulstorm, DOW II, Gothic Armada, using POL - no problems with any of them either on install or when running them.

As for the other applications, try searching the net for "Wine access violation" to see what results you get.
Also try asking here: GamersOnLinux

1 Like