Zorin can't find my Nvidia card

Hi all,

I believe I once disabled my Nvidia card in the nvidia-settings to check whether that could make my computer more silent, but since then I have been unable to turn it on again.

Trying to open "nvidia-settings" gives me:

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system
(nvidia-settings:75886): GLib-GObject-CRITICAL **: 19:57:47.050: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 19:57:47.053: PRIME: No offloading required. Abort
** Message: 19:57:47.053: PRIME: is it supported? no

This despite I have enabled the propriety drivers for it in Additional Drivers. In BIOS I can see my NVIDIA GeForce RTX 3050 Ti Laptop GPU, but when I look for it in Zorin this is all I get:

lspci -k | grep -A 2 -i "VGA"
0000:00:02.0 VGA compatible controller: Intel Corporation Device 9a60 (rev 01)
DeviceName: Onboard - Video
Subsystem: Dell Device 0a61

Has anyone else experienced something similar?

Did you check if secure boot is turned on ? if it's on please turn it off.

Thanks, I just tried it, but still the same result. Tested a couple of the different options under "Additional Drivers" but nothing changed

Is the nvidia card listed when you open terminal and write lspci ?

1 Like

Unfortunately not. This is what I get when I run lspci and reach for "nvidia", but I don't think this is the graphic card.

lspci -k | grep -A 2 -i "nvidia"
0000:01:00.0 3D controller: NVIDIA Corporation Device 25a0 (rev a1)
	Subsystem: Dell Device 0a61
	Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
0000:74:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5260 PCI Express Card Reader (rev 01)
	Subsystem: Dell RTS5260 PCI Express Card Reader

That is the Nvidia card...did you blacklist the noveau driver in the past ?

I can ask you to use my tutorial to install the nvidia driver, this because the drivers in "additional driver" don't fix anything. I don't know IF it will work since you also have a intergrated video card. It might work, it might also result in error's.

Oh, is it? That sounds good, I expected it to be listed as a 'VGA compatible controller'.

Thanks for the tutorial, will check it out!

If you google this part NVIDIA Corporation Device 25a0 you see what the results are ;).

1 Like

Oh, that sounds interesting. I guess things haven’t worked out as I hope so far. Tried to follow the guide and either if two things happen when I reboot:

Does Zorin have any kind of recovery mode that I can access without having the Grub prompt enabled?

Reboot, go into bios and load default settings and save.


Turn off hybrid graphics in the BIOS

Great, thanks, will try!!

Thanks @Michel , everything worked and I am back in my system again!

Installing the driver from the command line interface did not work, but I cleaned up all the old nvidia files as you wrote.

So back again in the graphical interface I thought I had nothing to loose in trying one last time in the "Additional Drivers" interface, and to my surprise it worked this time.

Must have been some old nvidia drivers causing the issue.


Glad everything worked out!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.