Zorin connect not finding laptop

My laptop is not discoverable on zorin connect after connecting my laptop to my phones hotspot. It just keeps showing no devices.

I get that once in a while with kdeconnect. 90% of the time, refreshing the connection by disabling wifi then reconnecting resolves it. Could you please try doing that on your phone and computer and see if your device becomes visible?

I tried that it still didn’t work. But is there a way to uninstall zorin connect and reinstall it on the laptop.

Yes, you can remove it by any of your preferred methods of removal, then reinstall it using the terminal:

sudo apt-get install zorin-connect

If you are using the connection via your wi-fi and you are using ufw you need to open the respective ports (but I admit sometimes this falls over after initial connection).
“d. Zorin connect
New to Zorin is the introduction of Zorin connect – with the Android app
installed on your phone you can use your volume button to scroll through
Presentations or a browser if you wanted to say make a presentation in html5,
the web browser gets mirrored on your phone so you don’t have to look back at
the presentation in the Browser on the interactive screen behind you!
Please note that if you have enabled the firewall you will need to create a rule
to allow Zorin connect to connect with your Android phone.
“If you are using a firewall on ubuntu, you need to open port 1714 to 1764. If
using ufw: run
sudo ufw allow 1714:1764/udp
sudo ufw allow 1714:1764/tcp
sudo ufw reload”
(Source: https://askubuntu.com/questions/1036351/how-to-install-and-run-gsconnect-to-have-android-integration-fransfer-files-se)
Alternatively, you could use the ip address of your phone to be allowed:
No. Rule
1
Anywhere ALLOW IN 192.168.xxx.xxx
Bear in mind that your router using DHCP may change on phone connecting to
router so you would have to add another rule. Whichever suits you best, go for
it. The app is also available on F-Droid as well as Google Play Store.”
[from page 32 of the Unofficial Manual for Zorin 15 Core]

1 Like

I have had the same issues in the past.
If you’ve switched the firewall on then you need to allow connect access. You can use the KDE Connect template to set up 4 rules to allow it. Also had an issue where I’d setup a VPN on both my laptop and phone and so had to setup split tunneling and allow connect to bypass the VPN.

1 Like