Zorin Lite hangs immediately after login screen (fresh installation)

Hi there

I have an old PC which I am trying to repurpose - Asus Pundit P4-P5N9300

I've tried installing Mint (all versions) as well as Zorin Lite. The installation is fine, but the moment I enter the username & password (at login screen), the computer boots into the desktop then freezes. The mouse pointer is responsive (moves around) but nothing is clickable and the keyboard presses are unresponsive.

I even tried installing Google Chrome Flex OS - that boots into the desktop and is responsive, but repeatedly crashes within minutes after the screen distorts.

Given the same thing happens on various versions of Mint and Zorin, I presume it is a driver issue. From the research I have done, it could possibly be the integrated graphics driver causing the issue. Does that sound right?

Can anyone help me troubleshoot. Would be great to bring this thing back to life.

Thanks in advance for your help.

P.s I am relatively new to Linux (being a Windows user) so please bear that in mind when giving instructions.

I am fairly new also but I think I can help. You apparently are getting past the boot screen if you have gotten to the log-in screen. When you see the boot screen that shows the line at the top moving to the right you want to hit the down arrow and go to advanced options if that shows on you screen. I am not using Zorin lite now so am not sure that option will be there. If advance options is not there then look for recovery mode. You then hit enter and it should boot up without loading any special graphics drivers. Try that and see what happens. Probably by the time you have done that one of our great gurus of this forum will be around to help you. Zorin lite is probably your best choice for an older machine.

Can you also check that you have done the basic pre-installation routine as described here:

@zabadabadoo many thanks for your reply.

Much of this doesnt apply as my PC is very old - it uses MBR (no UEFI options in the bios), equally no secure boot etc.

I've also tried installing various editions of Mint and Zorin. Rufus has been used to create the USB stick in each instance.

@citfta I did as you suggested and selected the generic boot option. That didnt solve the issue (same problem of freezing once it boots into the desktop).

I also ran various recovery options (repair broken packages, updated the grub bootloader, enabled networking etc).

What now?

I'm sorry that didn't help. I don't know enough to make any more suggestions. I guess you will have to wait for one of our more experienced members to suggest something. When you tried the various recovery options were you trying them with Zorin Lite? I do know that Zorin lite is 32 bit and Zorin core is 64 bit. I have a couple of old laptops that will run Zorin lite but not Zorin core.

I didnt know that lite was 32bit. That said Mint (64bit) had the same issues.

I read there are issues with Nvidia drivers:

I followed the instructions on Solving freezes during the boot sequence.

I have just tried this on Zorin, but it didnt work either - I entering the nomodeset with the my Zorin install. I made the nomodeset entry then continued to boot by select the Zorin generic option.

Unfortunately, it booted into desktop and then froze.

Hoping that others can help :crossed_fingers:

Zorin OS 15 Lite was the last version to support 32 bit.
Currently, Zorin OS 16 Lite and Core both are 64bit, only.

Looking up the specs on your machine, it looks like it comes with an older integrated Nvidia graphics card. Can you confirm or refute this?

In respect of the Nvidia question, yes this is correct - it has old integrated Nvidia graphics

It may not be supported by the modern Nvidia Drivers. And without an intel Integrated graphics chip to fallback on, the nomodeset parameter will not be helpful.
I wonder if you may be able to boot into the tty terminal, then install a supported older Nvidia Driver- Do you know the model number of your Nvidia card?