Zorin on LenovoThinkPad X260 does not start after applying updates

I have installed Zorin on different laptops, now I am writing from a Toshiba Satellite with Zorin OS 15.3 core. On my other laptop, Lenovo X260 ZorinOS runs well after a fresh install, ONLY if I don't install the updates. After applying updates it hangs on startup, does not bring the ZORIN Logo at all, it only shows a blinking cursor on the top left. That's all.
Today I tried to install the OS 16 beta, I hoped that could overcome the problem, but the installation iso now has the same behavior, it does not start, it hangs the same way, after the menu selection.
I was just curios if someone else has experienced similar problems.
Thank you.
Helmut

Please see:

Problem is with some update for the nvidia graphics driver.
I've done some research, and could fix it:

inxi -G
shows:
Graphics: Card: Intel Skylake GT2 [HD Graphics 520]
Display Server: x11 (X.Org 1.20.8 ) drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (SKL GT2) version: 4.6 Mesa 20.0.8

so I updated my driver:
sudo apt install software-properties-common
sudo add-apt-repository ppa:graphics-drivers
sudo apt-get install nvidia-384
sudo apt-mark hold nvidia-384
nvidia-384 set on hold.

This link helped:

Probably it can be solved also with some grub cmd line start parameter, I'm happy with this solution now.
H.