Zorin os 16.3 lite not showing wireless internet and icon, just showing Ethernet

Ohhh ok that makes sense I thought u were just seperating the lines with this | lol but I’ll try it soon thanks

Yea I fixed it, it was really easy aravisian helped with most of it I just figured out what I had to turn off tho

1 Like

The | is a pipe and piping a command is a means of directing a command to another command via a direct connection between the two.
That is where the name "pipe" comes from; if you imagine plumbing pipes connecting to route one source to another source to meet at a final output.

1 Like

Ok thanks

I entered the full thing it also did nothing like rfkill list

No worries - if everything is working now that shouldn't need attention :+1:

What I did find on that make / model: https://support.hp.com/us-en/document/c03522674 <-- Just in case you need to identify any hardware. Was expecting to see a BCM wireless chip, but nope - Ralink!

Nothing has changed it’s kinda still the same

This is all I see the exact same thing

When I press edit connections then press the + symbol and select add Wi-Fi this menu comes up but I enter everything and well nothing happens

Was confused - thought you meant WiFi was figured out..

So, this is where the dmesg command would come in - with my last pic post, try entering that command, sudo dmesg | grep -i wifi or, since you're using Ralink - sudo dmesg | grep -i ralink - that way it'll show you just the Ralink status from kernel. Post the output of the command, it may not be loading the driver correctly, or the correct driver.

Also, if there's no output of just rfkill list - try sudo rfkill list, you'll need to enter your password - but that should show something like:

Screenshot from 2024-01-31 17-54-24

It may be soft / hard blocked, which means there's either a blacklist file preventing use from the wireless chip, or there's a physical button / switch for your WiFi, on and off. Sometimes a Fn+F## combo - F1-12 depends on the make / model.

I did the ralink thing and nothing again it just says enter password which I did and then it just shows the green line thing so I can enter another command

Sudo rfkill list did the same thing

Tpm chip thing was not the wifi my bad

What do you get with lsusb? I didn't see the Ralink in your lspci output..

That's some info on the chip, if that is in fact what's being used - the Ralink. Says supported in 22.04, and 'detected' with 20.10 - Zorin 16.3 is based on 20.04... I'm beginning to think, maybe.. it isn't supported with 20.xx versions of Ubuntu or derivatives..

How much RAM and what CPU are you using? You may have a different outcome with Zorin 17 Lite..

I’ll try that tomorrow morning my sister has to sleep for school and the pc is in the same room so yea

Thanks for ur help

My vendor is Broadcom inc

No worries --

Your Ethernet is, yes - I can see that with your lspci output - but that's the only BCM device I see :thinking:

Are you sure it's a BCM wireless device? The HP spec sheet I posted has that BCM Ethernet but, also the Ralink RT2790 under HP 802.11 b/g/n - unless that chip was changed.. Did you change the original WiFi chip?

Just when you can; post the output of lsusb. I have another laptop that has internal WiFi, but registers on the USB bus..

It’s 00:54am for me idk about u but whenever I’m up I’ll do that

What is the output of

nmcli dev status