Zorin OS 17 desktop crashing when wake

I also have a similar problem. When I wake up my laptop from sleep mode, it shows the login screen. After I enter the password, Zorin silently crashes (no error message) and I have to re-enter the password. The laptop boots just like it has been shut down before (all opened windows are gone).

Zorin 17 stable, 6.2.0-39-generic, HP Envy x360 Convertible Model 15-ee0167ng.
Haven't had the isses on Zorin 16, so it might be a Wayland issue

1 Like

I have a similar issue on a 2014 MacBook Pro. Did you find a reason or solution? So far my fix has been to go back to Xorg vs Wayland.

Anyone else found a solution?

1 Like

Second post in this thread is solution, maybe you missed it? Scroll up

This didn't work for me. Still crashes

1 Like

Gnome Crashing from wake is a pretty long standing issue and there can be m any causes:

If you do a net search, you will find a lot of hits. The first thing I would try is disabling all extensions except for the Zorin App Menu. Test if Gnome crashes. If it does not, start re-enabling extensions one by one and testing after each and see if it starts crashing after a certain extensions is enabled.

I have same problem with AMD on PC.
I had to restart PC because still when I locked it and entered the password, the whole session crashed. Current Linux kernel I have 6.5.
I had to disable locking, because it happens randomly. Yesterday I clean my PC and installed Zorin 17 on my PC. On Zorin 16.3 I did not have this problem.
Zorin 17 looks to still be Beta. :frowning:

Clean new install Zorin 17.
All updates are up-to-date.
Session crashed again from wake after typing the password.
I use a Logitech MX3 mouse with original Bluetooth dongle.

21:42:48 pulseaudio: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
21:42:44 gdm-session-wor: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
21:42:42 systemd: Failed to start Application launched by gnome-session-binary.
21:42:42 systemd: Failed to start Application launched by gnome-session-binary.
21:42:40 systemd: Failed to start Application launched by gnome-session-binary.
21:42:40 systemd: Failed to start Application launched by gnome-session-binary.
21:42:39 gdm-session-wor: gkr-pam: unable to locate daemon control file
21:42:22 gnome-session-b: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
21:42:22 gnome-session-b: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
21:42:22 gnome-session-b: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed

Make sure you had disable fastboot and secure boot.

fastboot and secure boot are disabled.
Before installation I set "Other OS". Others to choose are Windows or Windows WHQL in BIOS. Session crashed randomly from wake.
I use Brave browser. Isn't there some bug on Gnome 43.9?

MB: Gigabyte GA-990FXA-UD3 R5
CPU: AMD FX 8350

Full log:

You may need the official 5.3 AMDGPU provided from AMD.

The only other option would be to try using the nomodeset grub parameter.

nomodeset works for Wayland?

I see this support link on Ubuntu forum with message:
As of at least late 2023, amdgpu-install does not work on any recent version of Ubuntu. There is a compile error in the dkms build. Either AMD doesn't care, or they've not checked their build logs in quite a while.
Jan 16 at 2:47

Maybe I'll try Ubuntu and if it crashes there too, I'll switch to EndeavourOS. At least I'll learn Arch.
I'm still using Windows because AI acceleration doesn't work for me on Linux because ROCm requires a Ryzen processor, and DirectML runs on Windows with no problems on DX12. Or I buy new PC with Nvidia GPU and I'm done with AMD.

1 Like

Yes, the nomodeset parameter deals with modesetting and is not affected by using Xorg or Wayland.

I am also experiencing a similar problem: when I try to resume from sleep it would let me put the password but then it won't go anywhere from there.

I have noticed however that this behavior varies with how long it's been asleep and with or without the external monitor connected... Back with Zorin 16 Core it didn't happen, though it would just shut itself off after a few hours and would have to restart anyways :frowning:

When I contacted support they said to: 1. set the power mode to balanced or saving, 2. use Xorg instead of Wayland and 3. update the bios. I have recently updated the BIOS and perhaps that helped... together with the solution offered in this thread.

I'll report if it worked later.

My OS: Zorin 17 Pro, 6.5.0-18-generic
ASUS Vivobook S13, i5-10th gen

I got same problem, I installed ZOS17 on my laptop Dell 3310 and it crashed when wake up.

1 Like

I have the same issue with Zorin 17 Pro on my LG Gram laptop.

1 Like

Newsflash... did a fresh install of ZOS17 (using the same file I downloaded 3 months ago) and now the situation has improved... However, there are still times the system crashes when returning from sleep (but apparently less than before).

Noticed that since the re-install it has now kernel 6.5.0-25-generic

Wonder if there is any relation...

This has not been a solution for me. I have tried everything that the support team has told (including a fresh re-install of the OS which actually seemed like the better fix, but after they told me to down-grade to kernel 5-15 everything got messy again). With the new install the kernel installed was 6.5.0-25... but after getting rid of LTS kernel 5-15I can't install it again, and now it's 6.5.0-14...

I have the exact same problem and absolutely nothing works for it. It is seemingly random, not every time it goes to sleep it crashes, just sometimes...although it is much more likely to crash than not.

1 Like

I have been having the same with my Asus ZenBook Duo (Intel i7 CPU). Having tried a few things, it appears to have been caused by the Zorin Taskbar Gnome extension for me. With all the Zorin Extensions disabled I didn't get any crashes. I then added them back one at time and the crashes returned only when the Zorin Taskbar extension was enabled. Using Zorin Dash instead of Taskbar did not give me any crashes.

1 Like