Zorin OS 17 - steam stuck loading user information

Hi guys.

New to linux here. I really love zorin from the first impression.

That said, i cannot launch steam. I am new to linux, with zero experience, so i would appreciate some help and perhaps some patience with me.

Steam is just stuck during loading the user information after login. I have tried this on 3 different machines. Same result. Also, even trying to login through the browser is timing out.

That said, i dont have any connectivity issues. My internet is working fine. Updating the OS, and installing applications from the software app works great. Time and date is automatically set.

One computer has an integrated gfx, the other a gtx 2070 super.

Can you help me?



1 Like

That didnt solve anything?

Installing steam through flatpak doesnt work.

I recommend the APT version, myself. Others recommend the Flatpak... When I tried it, I had several key problems I needed to solve to give it access permissions.
You might first run in terminal:

sudo apt install --reinstall steam

If it shows any errors, please relay them here.

Check your user account. I ran into some trouble with Steam that happened when I accidentally tried logging in with a Steam account I originally made, then let lapse and created a new one.
I totally had forgotten that I had made two accounts... :shushing_face:



It actually seems to work on the one computer. I will test with the other pc today.


Hi again.

Just wanted to write that your solution worked on both computers.

Thank you!

This leaves me with the question? Why didnt the steam installation from Flatpak work?

If others can replicate this, why isnt the flatpak version flagged as being broken?

As for feedback, i think it would be good for users to rate the apps of the software store, such that others can evaluate whether to install them. Perhaps even submit request for the app not to be accessible through the software store.

Again, i thank you for your help.


The Flatpak may have not worked due to Flatpak packages inability to access system files. I am not sure without examining your specific setup.
The Flatpak version generally works for most users and it may even have been just a bit of bad luck, too.

I decided to reinstall zorin, to make a clean bootable backup using rescuezilla. Trying to lean linux.
After that, remember completely clean installation - zero applications - i installed steam using apt, and now i am back to stuck at loading userdata.


Is going on?

Are you running X.org or Wayland?

You are not alone in this... Looking it up on the web, I see Windows users, Steam Deck users and Linux users all voicing the same complaint:

1 Like

I dont know. Just installed zorin, the installed steam using either:snap, flatpak or apt.

Either way, cannot login

Oh okay, at least i am not suffering alone. I did several websearches, but didnt manage to find any mention of it other than old posts.

Read the post you linked. Tried creating a ticket for steam support - but i cannot login to the web either on my computer using zorin. But i can on my phone?? Wtf?

These are recent and sadly, I am recently struggling with Steam working (after all these years of it working flawlessly) as well. I have uncovered little in the way of solutions.

I managed to get steam running with snap - but it is slooow..

I might have am splution, if ypu are willing to try it?

It requires you to use the steam mobile app, link your phone with your account and sign in using QR.

If you try this, tell me if it works please.

It did for me at least

Unfortunately, my issue with Steam is a different one. I am not stuck at loading user information.
Instead, it is failing to communicate with the Steam regional server properly and one title will not launch no matter what I try.

I have tried my solution on both computers, and it seems to be working - for now.

It seems that there is a problem with the Guard code from steam. To solve the problem of steam getting stuck ' Loading user information' i installed the steam mobile app on my phone. Linked my phone to my account, and signed in using the QR code. This seems to work using the steam installed from apt.

I will flag this as the solution - until ot changes.


Okay, that is strange.??

Can you specify what exactly is slow? Starting the client, browsing, starting games?

Would you mind sharing the game's title?

Since there are so many variables and one has to start somewhere—have you guys tried switching DNS servers to Google (, Cloudflare ( or Quad9 ( to rule out problems from that direction?

Especially your ISP's DNS servers can be funny at times. Some ISPs have even been found to block ports required for Steam and Steam games:

  • 012.net (Steam traffic blocked)
  • Bluewin (Firewall blocks Steam from provider side - must be disabled through provider's service portal)
  • Dutch Telecom (Steam traffic blocked)
  • ISPFree (Steam traffic blocked)
    Micronet Broadband (Steam traffic blocked)