Zorin os lagging

Hey everyone,
I have installed zorin os lite on my thinkpad l430
on booting up the logo lags and stutters a lot.
and after logging in the system is barely usable because of lag

Here is my system info:

ayush@ayush-ThinkPad-L430:~$ inxi -Fzx
  Kernel: 5.15.0-78-generic x86_64 bits: 64 compiler: N/A 
  Desktop: Xfce 4.16.0 Distro: Zorin OS 16.3 base: Ubuntu 20.04 LTS Focal 
  Type: Laptop System: LENOVO product: 24663D1 v: ThinkPad L430 
  serial: <filter> 
  Mobo: LENOVO model: 24663D1 serial: <filter> UEFI: LENOVO 
  v: G3ETB6WW(2.76) date: 09/18/2019 
  ID-1: BAT0 charge: 7.9 Wh condition: 7.9/57.7 Wh (14%) 
  model: SANYO 45N1023 status: Not charging 
  Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20753 
  Speed: 1281 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1211 
  3: 1197 4: 1213 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.13 driver: modesetting 
  unloaded: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 21.2.6 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.15.0-78-generic 
  Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce 
  v: kernel port: 4000 bus ID: 06:00.0 
  IF: wlp6s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 2000 bus ID: 0c:00.0 
  IF: enp12s0 state: down mac: <filter> 
  IF-ID-1: usb0 state: unknown speed: -1 duplex: half mac: <filter> 
  Local Storage: total: 585.00 GiB used: 6.54 GiB (1.1%) 
  ID-1: /dev/sda model: SSD size: 119.24 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST500LM021-1KJ152 size: 465.76 GiB 
  ID-1: / size: 113.45 GiB used: 6.53 GiB (5.8%) fs: ext4 dev: /dev/sda3 
  ID-2: swap-1 size: 2.93 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
  System Temperatures: cpu: 48.0 C mobo: 39.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 209 Uptime: 7m Memory: 7.58 GiB used: 1.18 GiB (15.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: N/A Shell: bash v: 5.0.17 
  inxi: 3.0.38 

please let me know what's causing this.

Are you dual-booting?
Did you disable Fast Start in Windows and Secure Boot in BIOS?
Did you check the SHA256 checksum of the downloaded .iso against published value before using it?
Some useful pre-installation advice for you to read here: Before you install

1 Like

First thing I'd do is check all the hard drives for errors... weak sectors can take a long time (I've seen one go as long as 5 seconds per sector to read on a drive that eventually completely failed) to read and write.

If the check does turn up any bad sectors, step up the frequency at which you do drive checks... if more of them pop up as time goes on, start thinking about cloning that drive, removing it, dropping in a new drive, then writing that .IMG file clone onto the new drive (all of which can be done via the Disks application while booted to the Zorin OS BootUSB stick).

1 Like

No, I am not dual booting I was using windows before
but completely wiped it out.

I figured the thing that when I boot my laptop with charger plugged
the lag and stutters will occur but after re-plugging the charger the lags stops immediately and the system works flawlessly.

what's causing this in windows there was no such problem like that.

I have just installed the wifi driver for my rtl8188ftv chipset.
which is working nicely, nothing else apart from this.

I figured the thing that when I boot my laptop with charger plugged
the lag and stutters will occur but after re-plugging the charger the lags stops immediately and the system works flawlessly.

what's causing this in windows there was no such problem like that.
please let me know.

Does the battery level indicator show charge state correctly?
You may need to do one or two power drain then full charge cycles, just to calibrate the battery meter and battery status in ZorinOS.

Also I would check your power settings, to see if anything is limiting performance when running just from battery.

1 Like

Yeah, it states charge state correctly.
the system is fine now.

but it lags a lot when booting up and is entirely unusable unless I remove and replug my charger.
I am curious what's causing this.

Was that with charger connected or disconnected?

FYI. I had some wierd BSOD issues on my Lenovo Windows laptop, even connected to mains socket. Whilst battery status appeared good. A new battery fixed the issues. If battery is old, then maybe think to replace, even to keep as a spare if no improvement seen with it.

The kernel is supposed to switch to the 'high performance' CPU governor during boot, then right before reaching the graphical shell, it'll switch to whatever CPU governor you've got set (I've got mine set to 'conservative').

I'm not sure what it does for laptops that are booting while unplugged... unless something has changed recently, it should be as above.

I did see one laptop that somehow got confused... when it was plugged in, it would switch to maximum power saving, and when unplugged, it would switch to maximum performance... might check that. It might be booting on maximum power savings (restricting CPU maximum frequency) because it's not recognizing either the battery or charger properly right during bootup, then when the charger is unplugged and plugged back in (after the boot has progressed and the proper software is running), it gets the signal to switch to high performance.

No idea how to fix that, though. Perhaps a higher kernel number?

I'm using:
uname -a

Linux HP-Laptop 5.15.0-92-lowlatency #102~20.04.1-Ubuntu SMP PREEMPT Mon Jan 15 13:24:57 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux
... on Zorin OS 16.3.

Also, can your machine boot and run without the battery (just with the charger)? If so, shut the machine down, boot into the BIOS / UEFI and write down all the settings so you remember them, shut the machine down, unplug the charger, remove the battery, plug in the charger, boot the machine (you may have to reset your BIOS / UEFI settings... laptops nowadays use the main battery to persist the settings, removing the battery resets the BIOS / UEFI to defaults), and see if the problem still occurs. If not, it's a battery problem.

And finally, it might be a BIOS / UEFI glitch. In this case, look for an update to the firmware from the manufacturer. My HP machine has already gone through 4 updates, and it's really helped to get rid of some perplexing glitches.

It happens with both be it plugged or unplugged.
I don't think the problem is with the battery. I removed battery and tried booting in the problem still persists.

I too thought that maybe upgrading the kernel will fix the issue.
But no help with it.

ayush@ayush-ThinkPad-L430:~$ uname -a
Linux ayush-ThinkPad-L430 6.3.13-060313-generic #202307200757-Ubuntu SMP PREEMPT_DYNAMIC Thu Jul 20 09:00:24 UTC x86_64 x86_64 x86_64 GNU/Linux

I booted my system without battery and the problem is still there.
though removing and adding battery makes no changes to BIOS settings.

@ayush222006, have you followed this suggestion, yet?

Yes, I tried it,
It didn't help.

I can see this as being either a hardware issue or a software issue equally easily.
It can be an issue with the charging port for the A/C cable (hardware) as readily as kernel.

However, this is the first I have heard of this report with a kernel that has been in use for a long time and is long term stable. I cannot help but think if it was the kernel, this would have come up before. This is an oddly specific issue.

Earlier today, I noticed that my mouse cursor was jumping around a bit. Or I would move the mouse but the cursor would stay put or barely move at all.
I turned the mouse over and noticed a wad of cat hair rolled up on the laser emission port. This coincides with us bringing in three strays from outside due to having gotten them neutered/spayed in preparation for getting them adopted to new homes (There were a total of 17 initially due to their breeding, but we set up an outside shelter and housed them and got them medically treated and spayed or neutered and have homed 11 of them so far).
From a new and unexpected source, came an unexpected problem.

I guess the problem is with the hardware then.
need to get it changed.

I keep my peripherals clean and tidy so there is no question of foreign partilces entering it.

It was heartwarming and wholesome to hear about the wellbeing of cats.
and lovely that they are being taken care by you.

Thanks for all the support by the members.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.