Zorin showing colour bars on screen after login

I recently got this error in which when I login to my user, zorin shows a black screen with static all over. Tty and the greeter work. I have zorin lite installed on my laptop.

P.S. I have no idea how to make a post so please forgive my illiteracy.

Do you know what graphics card you have in the laptop? Is it Nvidia by chance?

Can you see a "gear wheel" icon next to your user login? Click on that and select login using X instead of Wayland to see if any difference. You can always go back to Wayland if not.

EDIT: I now see from your profile that you are on Lite. Is that 16.3 Lite?

I have inbuilt graphics I'll try using x11 and notify you.

My previous advice assumed you were using Z17 Core, which defaults to Wayland instead of X11.
So my advice is incorrect if you are actually on Lite.

I tried swapping to x but there is no gear wheel so I'm using x

Are you still on Z16.3 Lite or something different?

Can you give details of your laptop, particularly its graphics card/s.

Did this behaviour happen after a software update?
You could choose to boot an older kernel to see if that returns things to normal.

It uses an amd from the dark ages the a6 9225 and I just swapped from Arch linux.And yes I'm on Z16.3

Its a fresh install and I cleaned the whole drive.

AMD graphics are usually supported by linux kernel.
Do you happen to know which kernel you had with Arch linux?

I do not sadly.

Can you provide an example of the error you are experiencing?

I am not going to be much help but this thread is similar; Black screen

Maybe @Aravisian will come along here and be able to help you with this as he is very conversant with Lite (xfce). But all are busy with issues with recently released Z17, so may need some patience. Zab

That is the experience even I thought it was a graphical error and did not install third party software.

and that is after login.

What does your screen look like before you login?

EDIT: Also have a look at this thread:

1 Like

It’s normal. Nothing unusual.

Please post a screenshot (we can't see what you see).

If it is a grub screen with "Advanced Options for Zorin" listed. Use that, and try a different generic kernel, if listed.

Sorry on my behalf.

Here is the login.

Hmmm. That looks much more different than any Zorin login screen I've seen.

Thank you so much, swapping to an older kernel worked I wish I could send a picture of how happy I am.

1 Like

Thanks to everyone who helped me.