Zorin Forum

Zorin windows app support installation problem

Hi, I have a problem installing zorin-windows-app-support:
zorin-windows-app-support : depends: wine32:i386
E: Unable to correct problems, you have held broken packages.

I've tried theese posts:
https://zoringroup.com/forum/5/15352/

P.S I'm using zorin os 16 core

Hi and welcome to the forum:

Windows App Support issue has been acknowledged by the devs.
See this thread:

2 Likes

Hi, I'm still having this problem with zorin windows app support. Ekrano nuotrauka iš 2021-08-23 21-14-36

Can you please run the following:

sudo apt --fix-broken install

sudo apt remove wine*

Once done, open Software & Updates and ensure you have no WineHQ repositories. If you do, please remove them.

In your Home Directory, remove the ~/.wine folder.

Once all of that is done run

sudo apt install -y zorin-windows-app-support

I did this before, but it didn't help.

I tried to install zoin windows app support with aptitude, unfortunately it says that it will remove these packages to solve dependencies:


149) zorin-desktop-session [4.2.3 (focal, now)]
150) zorin-os-default-settings [16.3 (focal, now)]
151) zorin-os-docs [16.0.1 (focal, now)]

1 Like

You did well cancelling that.:wink:
Did you add 32 bit architecture support?

sudo dpkg --add-architecture i386

That list looks like aptitude was trying to remove all 64 bit packages and revert your system to a 32 bit system (and hopelessly break it).

Yes, but in Z15.3 I installed app support without it.

I was thinking so too.

I need some clarity here...
Can you post the terminal output of

sudo apt update

sudo apt remove wine

Not much :smiley:

Looks good.

Open Software & Updates application and set yourself to "Main Server" in the drop down menu on the first tab (Download From), not a local regional mirror.

I was exactly doing this, but it's not working.

Can you post the output of

dpkg --print-foreign-architectures

dpkg --print-foreign-architectures

i386

Ok, I am stumped.

Testing this on mine works flawlessly.

Have you run:
sudo apt-get -y install software-properties-common

Maybe one of zorin devs can help?

Yes, it's installed.

Yes, at this point - you have installed Wine- that did not work. You backed up, removed all - then installed zorin windows app support and that also did not work.
It's probably something simple... that we missed.

I was installed lutris just after Z16 installation, but now I removed it