Frustrations with Zorin -

Seven Zorin installs before I think it is finally SEMI usable.

1st -Zorin NEEDS a simple install program for downloaded programs that are NOT in Zorin’s wish list App Store… Apache Open Office Linux 64bit version but when downloaded the App Store will not see it either in the listing or when searched for. I’ve spent 4+ hours attempting to install this.

I manually set some of the Apache Open Office deb files to run as executable and then did the install that opened. It put those specific files into the App Store Installed list but program does NOT Run.

I hate Libre Office as there are a number of things it can not do…(More hours wasted reading manuals and searching through the program). Simple basics that both Apache & MS Office have done for decades.

2nd- Can’t create NEW FOLDER??? What? I cheated and added a bunch of blank New Folders to have for later use.

3rd - Search. IF Zorin doesn’t like what you enter into search, it will NOT search. And specific searches will come up with some (to me) strange results.

4th - Help. Hate to give any credit to Bilgate’s mistake but F1 in almost any window it will at least offer help - right or wrong.

5th Start menu - yep it could use a lot of massaging BUT I have to premise that with my limited successful (more frustrated) experience so far using the Zorin OS.

6th - Task Mgr… 4 of my reinstalls were pure frustration that the only choice is to power off the machine. No ability to kill a locked up app. It can take ten minutes before Zorin is fully operational. I also had issues of Zorin powering my video. 2 screens that on two installs and doing the driver update after the required restart it failed to “see” the #2 monitor (at least for 20 minutes). Do it all over again. Finally got smart and first thing I did was that driver update and left it as the generic not the recommended.

7th password- WHY if I do NOT want password protection is it mandatory? And it can’t be just one letter or the space bar. I can’t tell how many times I have had to put my unwanted password in to unlock or grant access to something. MY machine in MY environment controlled by MY access. Maybe a login password at start up but too many other places want me to confirm its me. Or Admin level and then users who need passwords to make installations or changes.

8th - A simple networking utility. So far from what I have read it looks like I have better chance learning Mandrin than adding Zorin OS machine back in to my private MS home network for file and printer sharing. Using a thumb drive to transfer data vs mapping a network drive is doable - not ideal.

I am getting there BUT this will machine never be more than a printer driver and backup storage venue for the most part. The crashed Win 7 Pro 64 hard drive OS it is replacing just sat there ready to print and accepting backups twice a week. It really hasn’t been used 5 minutes a month for the last 5+ years prior to the crash warning and hours trying to recover it. Just IF I need it that it will work without problems. Like my 2002 Subie I drive once a month to get groceries. Unplug the battery tender and turn the key - simple.

Compliments on Zorin finding and accepting my old HP laser printer. Sees it but it hasn’t printed anything yet so I am still hopeful. I print 4 mail envelopes and 3 pages twice a year for my Dr. Ya that is all - email PDF if someone needs docs.

When I first moved to Linux, starting on Zorin, from Windows; It was a nightmare. The new and unfamiliar made it much harder to do anything, as I had to learn HOW to do even simple things before I could learn how to do the things that I wanted.
But in learning, I began to realize how dependent M$ had made me on things that do for me instead of doing for myself.
Programs, on ANY Operating System, tend to work and install better when the user takes full control of the process.
To install Apache Open Office, please follow this guide here to the letter:

Remove Anything you have installed with Apache and remove Libreoffice before proceeding.

I do not understand this. On my copy of Zorin Lite, I can right click in the file manager (Or use the menubar) and select “New Folder” using Nautilus, Nemo, Thunar or Caja. Can you please clarify what action you are taking and what the result is?

Some results may look strange just because an app developer used a different name than one you might expect. For example, the actual name of the app for “additional Drivers” is… “Jockey.”
-shrug-
The Zorin Menu will always search- but if there are no results, then it will not display results. If you get no results on a search, then that means what you have searched for is Not Installed and you may need to check your installation.

On both of the above- I will admit I rarely ever use the Zorin App Menu. The Zorin App menu is simple and elegant, easily finding and navigating for common usage. But users that do a lot of customization or custom installations, I prefer a different and more robust menu. For Zorin Lite, I use the Whiskermenu. Adaptable and configurable, with a great deal of functionality.
I use Cinnamon on Zorin, so on that I use Cinnamenu (on the right monitor) and Stark menu (on the left monitor). Gnome (Zorin Core) sadly has less Menu options available, but maybe some Gnome Users can chime in.

If you have trouble with Installations - Please feel free to come onto the forum and ask. Installations on Zorin are generally very painless but as I said at the top of this post- when something is unfamiliar, there can be a learning curve there. Chances are, we can help.

the xkill function comes preinstalled with Zorin. If you need, you can use your Keyboard settings to set a keyboard shortcut to run xkill. For me, I have it set to ctrl+alt+k
Hitting that key combo turns the mouse pointer into a Target- which I then click on the offending window which Kills the Process.

Are you talking about Boot time? That is very slow if so and implies that drivers are looping until the system goes fallback. Usually, this is the Video driver. Do you have Nvidia card? You can start a thread on Boot time and we can try to suss out what is going on there.

The password deals with ROOT. Anything that access ROOT or installs to ROOT requires the ROOT password. I admit openly on the internet, though, My own root password is a four character easily typed string.
One workaround I use when I am in a hurry is I open a terminal, enter “sudo -i” one time, then launch apps that need root access as needed from that terminal session. They then launch normally without giving the PW prompt.
Admittedly, I only do this when hurried and dealing with a lot of ROOT access.
EDIT: I almost forgot- I once used a two character password on an installation of Zorin Lite: It was “pw”. (I no longer use that- but yes, that can be done.)

Have you tried Samba?

If it sees it, that means you have every reason to be hopeful. As long as it sees it, it can print- as long as it knows which drivers to use. Normally, I open the settings and direct to CUPS. But on my other Canon printer, I needed to go to the Canon website, get the driver - install it- then open settings and tell it to look at that driver. At which point it was printing no problem.

1 Like

I only those solutions to half of the cents that you need, so I hope this helps you to get a bit more comfortable. I’m in the process of completing the three volume series “Using and Administering Linux” so then maybe I’ll be able to answer your other questions at a later date.

1). Use Synaptic Package Manager
2). Ctrl Alt t -> opens a terminal (command line interface or cli) where you can navigate your file system and issue a make directory (folder) command mkdir
4). Most programs have a command line interface, and the manual is accessed through the terminal. For example, to see the task manger on your machine you should run the top program, and to see its manual you’ll run man top from the cli.
6). Your terminal based task manager top can kill processes by pressing k followed by the process id. In regards to the monitor issues, you may use the fglrx software to configure an ati chipset.

2 Likes

Jacques
Thank you.
Yep Mandarin would be easier. When I get Open Office installed I am going to print 3 envelopes I need for the next 8 months, turn off the monitors & walk away. April I’ll have to print 3 pages of BP readings for cardio and its done until October’s next cardio…
1

ONE of my issues is I can’t tell what the video is. HP specs do not state which video it was built with. MS Device Mgr and I would know… Kind of things that to me should be basic installer info - CPU ram drives video controllers display… basics. The driver update process downloaded a Navidia driver and I tried it twice and at restart it would not boot at all first time and second it only saw one monitor. Two reinstalls and then with the other downloaded driver it hung. 3rd reinstall on just the video… but it seemed to finally come through after about 5 minutes.

I finally looked for & found the installation CD for the monitors but then I realized it was from 2003… maybe I should try it…

My full on version does NOT have a “create” a new folder. Trash - Copy To - Move To - Rename ------ Yep baffles me. As soon as I can figure out how to take a screenshot I’ll include one.

On my Full On version it just will NOT search - nada - nothing. Even the downloaded Apache Open Office files, the app store will not find it. I know it is there but the search will not find it. i have a TXT file e-mail.txt. Enter that in the menu search - nothing. Won’t search won’t even tell you that it does not find anything.

Tap the PrtScrn key to take a screenshot.

ohhh… Misscommo- I thought you meant the Zorin app Menu above. The App Store (Ubuntu Software Channel) is uhh… My diplomacy breaks down.
I HATE the Software Channel and I never use it. Mainly, because I find it clunky, uninformative and Useless.

I agree with Jacques 100%. If you need a GUI package manager, use Synaptic.
From terminal run

sudo apt install synaptic

Then open Synaptic from the App menu (Yes, you will need to enter Root Password, sorry) - you can use the Search Button at the top to search for either Installed or Not Installed software.

In terminal, please run:

sudo lshw -C display

That will display your Graphics Card information.
If you prefer a Device Manager-like GUI app, you can use HardInfo (It is what I use if I use a GUI manager):

sudo apt install hardinfo

Once installed, you can launch it from your App Menu and use it normally.

KOOL!!! works great. Only possible issue is it saves as png. Can it be set to jpg?

THANK YOU

1 Like

Empty desktop space - right click opens a menu that offers New Folder & Open Terminal Window. Folder can be moved with file management.

Install failed.

video info - ideas as to what I do now? I trid shutting off the #2 monitor and changing the display setting to only #1 but it did not make a difference in performance. Almost anything I open other than File takes 45-90 seconds before you can do any input. Mouse moves but nothing can be selected so can’t open a terminal and xkill it.

Done. – It still does not find Apache Open Office or openoffice - screen shot of files are there. Maybe I should do a new download and use Synaptic as the “open” program…

Yes, you can. There are two ways- One, use a Screenshot GUI app that allows you to set the file type when you save it- gnome-screenshot or xfce4-screenshooter will do it.
The other is to change the filetype in the .xml configuration file, but I suspect you may want to try another avenue, first.

Which Desktop Environment are you using (or put another way, are you using Zorin Core, or Ultimate or Lite?)

You can only run one ROOT installation at a time. If you are running Synaptic (Or Synaptic is open), then dpkg cannot get a lock in terminal because Synaptic has the lock. If you are running an installation in terminal, Synaptic will not be able to get a lock, for example. Whenever you see the error that it could not get a lock- Just finish the other installation, first.

I think this issue needs a new thread. But I agree with Carmar in the other thread- I would encourage you to reinstall, choose Zorin Lite and set it up with nomodeset and then we can Update your drivers.
I started out on Zorin Core (which uses Gnome Desktop environment) and it was nothing else except a lesson in frustration.
Gnome is not user friendly, they have removed or hidden a lot of features and to anyone moving to Linux, Gnome aggravates more than it helps.
XFCE Desktop is Much more user friendly. Settings are generally easy to find and are highly configurable. The problem solving and troubleshooting is usually easier, too.
I have never had Printer Connection troubles on XFCE, I always did on Gnome.
Gnomes File manager is clunky, hard to configure, hard to find the settings, right click offers fewer options…
Zorin Lite is Just Plain Better for someone starting out.
That said, the “lite” seems a bit misleading. it is not lacking in anyway, it is just not Resource Heavy like Gnome is.

Synaptic is a very useful and powerful Installation tool. But it also can only find and show what is in the Repository you have. I gave a link with Apache Open Office Installation instructions above.
Apache Does Not Offer a Repository… (cough)


Thanks that got me 40% there. Then search of Apache Help gave me some other commands that got it installed. But what now baffles me is copying the open command to the desktop responds with a “not valid command”. And I do not have permission to change it.

In the menu I did find it buried along with still Libre ■■■■ commands. I did the one thing I need Open Office for and won’t need it again for 2 months to print a report for my cardiologist.
i am used to taking a Windows shortcut and copy & paste anywhere I want it. This baffles me.

I messaged Zorin supposed installation help for assistance two days ago and NO - ZERO - response on the possibility of downloading a different version. And instruction for the commands to remove Libre.

I didn’t include this before.

Searched NIVIDA for the driver GeForce 9100 and downloaded it. It comes up with an installation error. Waited 30 minutes for Chat Help without anyone responding. I’ll try again tomorrow AM.

You can download any version of Zorin at any time from the provided links:
Zorin 15 Ultimate, Core and Lite are ready for download right here, on the same server as this forum:


If you would like an earlier release (For example, Zorin 12), these are archived here:

As far as a response back from the Zorin Team:
Please remember that the Zorin Team consists currently of Two People: Artyom and Kyrill Zorin.
They respond as fast as they can, as well as actively developing Zorin 16, still in development.
Fortunately, the forum is here with many members eager to help.
I know the frustration… When I left Windows behind, starting out on Linux with Zorin 12… It was a shambles. Everything seemed so unfamiliar and even the most basic and simple tasks had become like pulling teeth. I spend at least a week just plain angry and hating Zorin OS. But… Learning began to accelerate the more I dove in. What seemed easy on Windows but hard on Linux began to do a reversal, as I realized that once I familiarized myself with the system, really learned how to use the tools at hand, it was Easier on Linux than it ever was on Windows.
Now, I am a Linuxer for life. It’s like having the Kings Feast and going back to Windows would be like going back to McD’s.
I can only ask you have patience. Like learning to ride a bike or drive a standard after learning on an automatic, it’s a bit frightening and intimidating and very frustrating at first.
But also worth every hair-pulling second once you get the hang of it.

I, personally, have never used nor installed Apache. I know Apache prefers to not support a repository, which makes installation a bit harder.
But I will need to learn how to do it myself, before I could really effectively help you on that one. But if you allow a bit of time, I will see what I can do.

As far as a different version:
If you would like to try out Zorin Lite (which is what I use, every day on all my computers) you can find the download here:


That may seem like a step backward- But I believe installing Apache would be a lot easier on Lite. Apache is not working as it is, now, on your system anyway.

In addition to Aravisian’s advice, please also see: Methods of downloading Zorin OS - having to do seven prior installs makes me doubt the integrity of your downloaded installation file.
It may be that your installation file is fine but I still recommend looking at that link.

More issue with the video driver… NVIDIA “driver program” today fresh download ran for over an hour and I had to do a hard shutdown again - not even the mouse would move. It usually moves but clicks do nothing when it locks up. Video delays often mean actions take 2-5-10 minutes before the next command can be entered. Earlier in this thread it was suggested that my first 2-3 reinstalls were just the video failing to properly load. Then learning curve and my fumbling through not knowing linux.

Thread has been tremendously helpful for a neophyte. Life saving in reality. Whole reason for trying linux was Win 7 recovery not printing and now finally I have Apache Open Office working. I am semi good. I’ve figured out how to fake network files from one to the other for printing.

I may try the Lite but not sure I want to chance having to cut my teeth all over again when I am at an annoying working solution. If it ain’t broke don’t fix it.

Everyone here THANK YOU Thank you thank you!

I wonder what the difference is between me being pushy- and being encouraging…
I started on Linux through Zorin Core (Gnome) and it was nothing but frustration the entire time. Getting the video drivers to work, getting things to customize, getting settings to actually Set Things… It was a non-stop struggle. And I dreaded the idea of Reinstalling.
And I did not re-install, instead I installed XFCE desktop onto Core. That was the final push to using Zorin Lite. I finally installed Lite.
And from there forward- Using Linux on Zorin was a breeze. Everything worked, no video driver problems and settings were easy to find and applied immediately.
Gnome is not user Friendly- even for experienced Linux users.

Perhaps you are not ready to face the idea of reinstalling- but if the time comes that you must or would like to consider it, I hope to encourage you to try out Zorin Lite at that time. But in the meantime, you could do as I did and install XFCE desktop environement, log out, click the cog wheel and change to XFCE desktop, and log in and take it from there as an alternative.

sudo apt install xfce4