Headphones output no sound

When I installed Zorin OS for the first time and plugged in my headphones, I noticed there was no sound. I started looking for solutions on the internet but none of them seemed to do anything. The settings look fine, the drivers look fine, and the salsa mixer looks fine too.

I asked for help on r/zorinos here. Basically, the speakers on my laptop work ok, but the headphones output no sound, but when over-amplification is enabled, the headphones output some sound but it is low and very distorted. There have been other people with a similar issue across many other sites, but I have tried everything, to the point that I am seeing repetition.

I then came across this site that had a slightly different solution to the dummy output problem here (I don’t have that problem, but decided to try it out anyway). Now neither my speakers nor headphones will output any sound, not even with over-amplification.

Has anyone else been in the same situation or has a solution for this?

Please see if any of these threads have suggestions relevant to your problem:
Headphones - Headphones showing working, but no sound at all
1 - Sound doesn't work
2 - No sound to speakers after kernel update

yup. I also tried all of the steps in this article by itsfoss but it still doesn’t work. I fixed the speakers’ issue (just had to reverse one of my attempts at fixing it), but the headphone sound remains the same.