How can I install the Intel microcode?

They have recommended it to me in a forum but they did not tell me how to do it

What is the issue that you are trying to resolve? Trying to give you instruction on someone else's solution can be difficult and may not even resolve the issue you are having.

Well, Zorin does not start, The screen flickers while the system boots, It has a poor graphical performance, it overloads very easily, it writes dots in the texts where I write and the animations lag.

I've been trying to fix all of this for months and already tried everything, this was the last solution I found.

Please ensure secure boot is disabled, even if you have to create a password for the bios (not a bad thing). Would you mind sharing your system information, including graphics card. When you used the live image, did it give you any problems? Did you go into try Zorin or did you just install?

Edit: I realize you are most likely frustrated from not being able to get it to work...but I will attempt to help you the best I can. This information will be necessary to finding a solution for you. Did you post this issue in this forum before?


Thank you FrenchPress....I didn't put the user together with the posts....I could have searched


I am using legacy mode

It is Zorin 16 Core and my laptop is a HP ProBook 440 G3 with 12gb of RAM I5-6200U CPU and Intel HD 520 graphics card

Well, when starting from the Live USB, the screen flickers while the system starts the installer and while doing the file system check, and I always hit Install Zorin

The solution they provided you may work, but requires you to at least be able to get to a tty in the os. It seems like you are having issues because the driver is can install intel microcode by terminal or tty with sudo apt install intel-microcode but I don't know that will solve your issue. Have you tried a reinstall?

The legacy mode may be the issue. I don't know if intel microcode will be helpful. You may need to wipe and set the disk up as GPT (automatically done if you wipe the entire drive and install Zorin/Windows with the bios not in legacy).

since i started using it in august i think i did ten or more reinstalls

Do you know if you have the latest BIOS for your laptop?

1 Like

I mean reinstall without legacy mode. Backup your windows data and wipe the entire drive so you are in GPT?

A few weeks ago I installed the latest version, it doesn't fix anything

1 Like

Estoy hablando española!

:rofl: Sorry, I don't speak English very well


You may have to face facts that you will have to move from legacy mode...This is one of the major factors in your issues. The square characters are indications that the fonts aren't installing or accessing correctly...this is due mostly because of video card drivers or legacy mode (the computer is confused looking for 32bit os and files but finding 64bit).


Backup your data, if you can't live without windows, install it first (64bit installer) then install Zorin 16. The only other possibility is to use Zorin 15 because that is the last 32bit version available.

Using the microcode solution will most likely not help. If it does you will have more issues in the future.


Makes sense, I'm going to install it again without the legacy mode to see how it works


Make sure you turn off legacy mode in the bios.


Intel and Amd microcode are installed by default as mitigation for the spectre & meltdown cpu vulnerabilities.

apt-cache policy intel-microcode
  Installed: 3.20210608.0ubuntu0.20.04.1
  Candidate: 3.20210608.0ubuntu0.20.04.1
  Version table:
 *** 3.20210608.0ubuntu0.20.04.1 500
        500 focal-updates/main amd64 Packages
        500 focal-security/main amd64 Packages
        100 /var/lib/dpkg/status
     3.20191115.1ubuntu3 500
        500 focal/main amd64 Packages

I have processor with gpu i7 4790k. Could be why on Zorin Pro sometimes i have black screen? In bios i have off. Screen i have from PCI-Express 3.0 that's means this could be a problem processor Intel some "virus" a spectre or meltdown???