My laptop has problems with zorin os

my HP probook 440 g3 laptop has problems installing zorin os for example

-installer stops at random times and is unresponsive

-the installer reaches the part where it copies the files but keeps loading forever and never ends

-zorin was installed correctly but then the system crashed and the pc had to be restarted

please help me I really like the system :frowning:

forgive my english if it is not understood i am using a transducer

Please see these: Before you install
Can you provide more details on how the system crashed after the first installation? What happened after you restarted it when it crashed?

Which version and flavour of Zorin do you have e.g. Z15.5 Core or Lite etc, or Z16Beta?

i am using zorin os 15.3 core

the system was installed correctly after several attempts then I started the system and my user then opened some apps and the system crashed

then when rebooting the system with the power button I would enter my password and it just wouldn't load after that and the system would crash

What were the apps you ran before it crashed and how did you install them (through Software Store, other methods)?
Did you see #1 on the link I posted earlier? Did you verify your downloaded Zorin ISO?

just connect my laptop to wifi i opened firefox and nautilus and the system crashed

Does it have something to do with the video driver?

since when starting the installer the screen flashes for a long time while "OK" messages appear repeatedly and hopefully the installer starts

I downloaded the ISO from the zorin page

Please follow these instructions: Methods of downloading Zorin OS - #8 by zabadabadoo

I downloaded the ISO from the ZORIN page and the USB is relatively new and of little use

with the ISO image that you download, install zorin on several laptops without any problem, the problem is with this laptop :frowning:

try to use safe mode and it doesn't work either

Your HP Probook should be using Intel i5 HD graphics.
Have you tried

sudo apt install --reinstall xorg


Yes, all good. But did you still check the SHA256 checksum to confirm nothing corrupted during the download?

1 Like

I could not because zorin never finishes booting, it just keeps blinking indefinitely while some letters or white codes appear

the check says that the file is fine

and I have tried with other distributions like ubuntu debian or manjaro and the result is the same it never starts

@Jesusito . Some questions:
Using Gparted, how many partitions do you have set up on that HP probook 440 g3 laptop ?
Are you intending to dual-boot Zorin 15.3Core alongside Windows or another OS?
Did you try an install using the "Something Else" method?

1 Like

It also appears that you are definitely not alone:

HP, of course, denies all responsibility.
This writer says he struggled with a very similar model but finally managed to get Ubuntu installed (Zorin OS is built off of Ubuntu) by using Boot Repair.

  1. the main partition and the efi partition

  2. I am going to install only zorin on the hard drive

  3. No

The writer has installed Ubuntu 19.04 as single boot. However, reading one of the comments:

"Hi Tyler, thanks for the helpful guide. I can confirm that the above works with Ubuntu 19.10 as well. It does NOT work on 18.04. Cheers!"

@Jesusito You could try Zorin 16 Beta, as Ubuntu 20.04 was reported to have worked.

1 Like

Try disabling the splash screen to see what's happening during the init process or when it hangs try to ctrl + alt + f1 to switch in terminal mode to see what really is happening.

I did and when I do, some codes appear that start with a number followed by the word "pcieport" and end with Identifier ID

Is it similar to appearance to this?