Installation of Zorin OS 15.3 Core freezes on Acer Aspire ES17

My installation has frozen on me in several different places during the install.

Before the install menu loads from my USB, I get an error that says Initramfs unpacking failed and that there was a problem loading X.509 certificate -65.
Despite those errors I can move on.
I have to connect to my WiFi to be able to unselect the option to get updates during installation. How does that work? (I turned them all off hoping it wouldn't get stuck). After that my loading cursor freezes for about an hour while working on grub-install /dev/sda. When I check, I no longer see any activity on my flash drive.

I checked the system requirements for Core. I've got an Acer Aspire ES 17 with an Intel Celeron N3350 4GB DDR3 L memory and a 1000 GB HDD.

I'm at a loss what to do know. I've read something about mounting and unmounting the partition, but how a I supposed to do that on a frozen system that doesn't react?

What should I do?

stijnhommes, welcome to the forum.

Were you installing on a drive that contains a previous copy of any operating system? Were you Dual Booting with another Operating system?

Is the drive HDD or SSD? Can you give specific details on the drive?

1 Like

This seems to be a kernel bug. See the bug report below:

This issue comes in some Acer laptops as its BIOS contains two obsolete certificates. The error message is harmless and can be ignored. Some patch is available for Linux kernel to hide this error, but its not part of Ubuntu yet.

You might also want to consult this excellent tutorial for preparing the system for installation:

I used a USB to install onto a laptop that previously had Windows 10.
I was NOT dual booting. Every single time I tried to install, I chose to erase the disk.

I'd have to double-check, but as far as I know the drive is HDD (1TB). (What would be the difference between the two as related to the installation?)

I can boot from the USB and try Zorin. I get into trouble when I try to install it on the hard drive only.

By the way, why was I only able to uncheck downloading updates during install after connecting to a WiFi network? I would expect to not install updates when there is no network connection by default.

From Windows 7 up, Windows featured the "Fast Boot" option. This option locks the hard drive preventing read / write access. As noted in Carmars post linked by FrenchPress above, this feature must be turned off in Windows prior to installing on the HDD.
In UEFI motherboard settings, it is highly recommended to disable Secure Boot in order to boot and install a Linux Distro.

Some SSD's are eMMC, which operate differently than standard SSD or HDD. Installing on them requires other steps.

This is a good question. I often would leave that unchecked and do the updates after the installation was completed. In skipping connecting, I did not need to ensure the box was unchecked for updates.

Because I've already done a partial install (and used the option to wipe the drive in the process) Windows 10 itself is no longer on the system, at least not in any recognizable and accessible format.

When I go to my BIOS, the option to change boot mode or change secure boot are greyed out. How do I make them accessible so I can change them?

Never mind about that last comment. I've disabled secure boot and am now trying to reinstall. Let's keep our fingers crossed.

2 Likes

Please update this thread if you still have trouble. If so, can you give your Graphics card details- Is it Nvidia or AMD or Intel?

I'll leave my laptop on for a while longer, but it appears that despite disabling secure boot, the installation is still freezing in the exact same spot during the grub install. Is there anything else I can try?

The graphics card is by Intel.

1 Like

Sometimes Nvidia Graphics and other graphics issues can cause freezing during installation. This seems not to apply to you at this time so...
When you boot from the USB, you can start bapping the esc key at the boot menu to pull up the Grub Configuration. Sometimes this is done with the e key (for editor), so if one does not work, try the other.
Once the Grub is pulled up, Scan the screen for "quiet splash".
You will need to navigate with the keyboard, not the mouse. Move to just after quiet splash and add acpi=off.

quiet splash acpi=off

Then exit as prompted at the bottom of the screen and resume booting. Once in Live Zorin, try the installer again.

If the above does not work and it is still freezing, please review this guide:

Do you mean I have to boot Zorin from the USB and select the install icon on the desktop? I've tried all the installations straight from the Zorin boot menu.

Yes, please follow the above route by installing from the Live Desktop.

Zorin 15.3 is based on Ubuntu 18.04.
This bug might be the culprit.

1 Like

O.P. got quiet. I got worried.
Hope this means he is going through the entire installation.

The grub file had 3 dashes after "quiet splash". Is it okay to leave them (and enter the additional code before them) or should I have removed them?

Yes, leave the dashes and add the acpi=off with one space separating it from quiet splash.

After booting from the USB and starting the install from the desktop icon, I'm now getting something different. Instead of getting stuck during the install screen, I'm getting some sort of blueish green desktop screen without any taskbar, application or workspace menus or icons (just a clock and date) and some stuff in the top right that isn't helping. I can hit a big pause button, in one of those. It looked like the install was interrupted because the bar wasn't full yet.

Is this progress or some other issue?

Definitely some issue, not progress. But what it may be is a clue to help point us in the right direction.
I've not heard of nor seen a screen like you describe (A picture taken with your camera phone may help visualize that).

Can you check in your BIOS settings if you are enabled in RAID or in AHCI?


According to the BIOS, my SATA is AHCI.