I've Switched From Windows 11 To Zorin OS 16.2! But I Still Have Some Random Questions

Well, as the title states it, I've decided to jump ship from Windows 11 to Zorin OS 16.2 for a change just to see how good the experience is! :slight_smile: [Do bear in mind though, that this is just as a "trial basis"; I will most likely jump back to Windows 11 after a few months or so if this doesn't work out.] So far, the experience hasn't been too bad given that I've tinkered somewhat with Linux before, but I am FAR from an expert on it since I don't normally daily drive it. For anyone curious, this PCPartPicker link contains all the components for my entire pc setup: https://pcpartpicker.com/list/t232Y9 Anyway, back to the topic, I have some general/random questions after getting it installed & hope someone here can help me sort these issues out. :arrow_down:

Question #1: I was trying to adjust the refresh rate & under the display settings, there isn't yet an option to do so. Upon doing a Google search, you can use xrandr to determine your screen resolution & refresh rate, etc. Now, right off the bat, I KNOW my display can do 2560x1440 @ 144 Hz. And under my display settings, it DID pick up the right resolution by default, but I seem to be running at the incorrect refresh rate. [After running the command in the Terminal, it says: "Failed to get size of gamma for output default" & I don't know what the solution for that is here since I only use 1 monitor anyway.

Question #2: I am not entirely sure if my settings are right... I'd appreciate it if someone can confirm for me after viewing these screenshots:

Question #3: When I try to view my graphics settings via Nvidia X Server Settings, it will open, but I'm not seeing ANY of the settings! Perhaps it has to do with the graphics driver I'm running or something? :thinking: With that being said, is it possible the Nvidia Control Panel can be installed on Linux?

Question #4: Does anyone here know of an app or something that can control RGB lighting on motherboards? I don't really use my system RGB much like at all, but I normally like to keep it off for the most part.

Anyway, those are the questions/topics I came up with. [May or may not have more later on.] But anyway, if any of you happen to have questions for me or need more details, feel free to ask & I will be sure to reply back! :+1:

Thanks in advance to whomever can help! :slight_smile:

It really is best to separate out different questions from one topic.
This allows users that search the forum looking for specific solutions to find them more easily.

Which command did you run?
Was it similar to:

xrandr --addmode HDMI1 1200x1000_60.00

Had you previously created the new mode?

cvt 2560 1440 144

Add the modeline you got from above.
It may look like:

xrandr --newmode "2560x1440_144.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

Don't copy and paste this one. I just made it up.

Then add the new mode:

xrandr --addmode HDMI1 2560x1440_144.00

Again, do not copy and paste mine. Use


to check your connection type. You might be using something other than HDMI1.

It's perfect.

Please add the Xswat graphics updates repository:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Then upgrade the drivers (and everything else)

sudo apt update && sudo apt full-upgrade

Yes, I use OpenRGB and on my system, it works perfectly. I like to turn off the Fan Lights at night...

sudo apt update && sudo apt install openrgb

You can find it listed in the app menu.

A post was merged into an existing topic: RGB lighting software for Zorin OS?

@Aravisian Sorry about throwing a couple different questions into this post here, but I wanted to sum this up in 1 post since it pertains to transitioning from Windows to Linux.

You asked which command I ran in the terminal- as I stated it earlier, it was the xrandr command; just that. I also hadn't created a new mode yet cause I didn't know it was needed nor do I know how to do it. [Remember- I'm somewhat of a newb here, but that doesn't mean I can't be a quick learner. :wink: ] As for question #3, I can personally guarantee you that I'm connected to my monitor via DisplayPort.

But yeah, if you have to E.LI.5 on some things here, I won't mind. :slight_smile: Just remember that I DO know Linux is quite different from Windows & things in general have to done differently. I appreciate you guys for bearing with me on this & for being patient & helpful. <3

1 Like

It's no problem at all. But I would like to separate the issues out, so that you and other forum members can keep the different issues organized and easy to follow.

Great - let's try the same steps above. You can ensure the right Device ID with just the terminal command xrandr. You should see DP0 or DP1.
Then run

cvt 2560 1440 144

Grab the modeline.
Run xrandr --newmode followed by the pasted in modeline. Just like the example above is formatted, but with your modeline instead: xrandr --newmode "2560x1440_144.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
Add the mode:

xrandr --addmode DP0 2560x1440_144.00

A post was split to a new topic: Nvidia settings not showing any of the graphics card settings

A post was split to a new topic: RGB lighting software for Zorin OS?

I checked via command, but I'm not seeing EITHER DP0 or DP1. What am I supposed to do in this case? :thinking:

Is nomodeset enabled? (Are you booting in Safe Graphics?)

sudo nano /etc/default/grub

Arrow key down to this line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
Remove nomodeset (If present)
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
Tap ctrl+x to exit the editor, the y key to say yes to save and the enter key to save as current configuration.
Then you must run

sudo update-grub

Once done, reboot and test.

IF the nomodeset parameter is not present... please say so.

I checked, but the nomodeset is NOT present. So, what do I do now?

Can you please post the output of

sudo lshw -C video

(This may explain your missing Nvidia Settings, too)...

@Aravisian These are the results:

Ah... Nvidia 2070...
Can you run

sudo nano /etc/modules

And ctrl+shift+v paste at the bottom


Then ctrl+x, y, enter

sudo update-initramfs -u

Reboot and test...

If that does not work, we may need to try lowering your kernel to maybe 5.10....

Okay, I'm going to reboot real fast & make those changes. brb

1 Like

OK. I disabled Secure Boot & then rebooted, but the Nvidia X Server Settings is STILL not displaying right! :thinking:

Also, you weren't entirely accurate earlier; I have a 2070 SUPER instead of a regular 2070, but minor details. :wink:

IS disabling Secure boot the only thing you did?

Yes. Was I supposed to have done something else...? If not, we can simply continue trying to figure out what's going on so. :man_shrugging:

Yes, please see this post:

OK, but what am I supposed to do here? I'm dumbstruck atm. :confused:

Nano is an editor for use in terminal.
Calling for SuperUser Privileges, sudo, you can run nano in Root:
sudo nano then specify the file to edit:

sudo nano /etc/modules

Arrow key to the bottom.
Copy the following here:


And at the bottom of the file in the terminal, tap ctrl+shift+v to paste, or right click and choose paste from the menu.

Once done, tap ctrl+x to exit, then the y key at the prompt to save, then the enter key to save the current configuration.
The terminal will revert to normal.
Now run

sudo update-initramfs -u

This should activate the necessary modules for Nvidia Graphics.