New kernel result in black screen

Hi, i have got an update last night of Zorin OS 16 Core and when i reboot everything went wrong and got a black screen.
I have waited for a long time but nothing boots into Zorin OS 16 Core.
So i have booted in an older kernel and remove kernel generic 5.11.0-34


The latest is not always the greatest. :wink:

Are you notifying the ZorinGroup? Or seeking assistance?

And... It's good to see you on the board, again.

Hi Aravisian, it is more notifying the ZorinGroup but getting some assistance would be fantastic.
Like why can't i have the new kernel?

I went ahead and moved the thread to the Feedback forum for the purpose serving as an alert to the performance of Zorin OS.
You have already "Solved" the issue by removing the regressed kernel and reverting to the older one. You probably already know (As you could teach me a thing or two about Linux) but for all other readers, you can use apt-mark command to lock your kernel for the time being:

sudo apt-mark hold linux-headers-5.11.0-27-generic

in order to proceed with all other updates as we all await a patch or a solution for Nvidia and Updated kernel.
Please watch your thread for updates.
When the kernel issue is sorted out, you can:

sudo apt-mark unhold linux-headers-5.11.0-27-generic

In order to release the hold on the kernel and update it as needed.

1 Like


The Zorin OS Updater is now offering kernel 5.11.0-36 over 5.11.0-34. Might be worth checking out and seeing if it works.

1 Like

Thank you very kindly...
I really appreciate what you're doing.
I will definitely mark this kernel to keep.
it is remarkable that with the program: extra drivers I don't have the option to choose another driver, it's as if this is fixed.
I know in the past with Zorin OS 15.3 Core I could mark the x.Org x server -- nouveau display driver for use and then install a new kernel, but here in Zorin OS 16 Core I can't change the choice.
There is now a radio button next to it: continue using a manually installed driver.
I didn't install a driver manually but I did a fresh install of Zorin OS 16 Core with the option: something else and chose to install Zorin on an ssd and keep the home partition on a hdd without formatting.
So that way a lot of things have been left behind the installation of Zori n OS 16 Core

A bit tedious, but maybe you can install any missing packages using the Zorin OS Stable repository. If you don't notice it missing, you may not need it. :wink:
But for that which you do, fortunately you can install any you see in the list with One sudo apt install command:

No need to add any repositories since it is already in your sources.list.d

Please be sure to notice the Update above regarding the 5.11.0-36 kernel over the 5.11.0-34 ; should you need to apt-mark unhold the 5.11.0-27.
The ZorinGroup responded quickly on this.

I have the server on main server in software and updates.
And notify immediately when updates are checked.
The kernel 5.11.0-27 I marked as unhold
but I don't get an update option to a newer kernel
Could you please explain to me how to install the new kernel 5.11.0-36?

In terminal, can you please run

sudo apt update && sudo apt full-upgrade

that command got me back to the kernel 5.11.0-34 instead of the 5.11.0-36
maybe it hasn't been released yet

1 Like

I was moving quickly in hopes of sparing as many people as possible from headache.
The 5.11.0-36 was offered on my end- but has now disappeared and is offering the -27 again.

I can only assume that the ZorinGroup noted that the -36 failed testing too.

I apologize for my zeal; Let's stick with the -27 for now.

1 Like

I added the kernel revision number to the title for clarification.

Per the OP's wish I changed back the title.

1 Like

Damn it yet. Don't change the topic title! This is not about kernel 5.11.0-35 but about updating to kernel 5.11.0-34!
And I don't have your problem, had you read the topc correctly you would have noticed that I can't change drivers.
Start a new topic instead of polluting this topic

Zorinhendrik, I certainly understand your frustration at logging in to find that an update combined with Nvidia caused a headache.
However, please review here:

We are all volunteers that seek to help. We can make mistakes or not catch the entirety of a situation sometimes, but should never be abused for our efforts.
That being said: You both experienced the same problem: The updated 5.11.0-34 kernel (I don't care about a -35 typo) and FrenchPress's comments are relevant and on topic.

1 Like

I don't agree with that at all.
FrenchPress is doing something here that would ensure that the problem is solved which is certainly not true.
I can't switch to another driver that FrenchPress could do.
That makes it something completely different.
I don't have one screen, I have three next to each other and in Zorin OS 15.3 I had an Nvidia driver but here in this case a manually installed driver that I can't change to the driver
I'm sure if I can switch to the driver I upgrade to kernel 5.11.0-34

My apologies to FrenchPress

And then this: sorry I'm schizophrenic and autistic.
I can't help but not accept FrenchPress' story as a possible solution and change the title to 35 instead of 34, certainly not.

Maybe it was a mistake on my part to seek help here

To fix this try:

sudo ubuntu-drivers autoinstall

FrenchPress is doing her job as Moderator to keep the thread accessible and to propose possible Solutions. If anyone was trying to "fake" a solution, we could just mark a post as "Solved" and then lock the thread. In not doing so, it demonstrates sincerity.

This forum is a guide and a resource for everyone. It must be a welcoming place that users can feel comfortable not only seeking help, but offering it. It must be welcoming for Lurkers and Readers to see that they will be treated fairly without undue assumptions, accusations or personal attacks.
Whether you choose to seek help here should be guided by those principles.

This is now addressed fully. Further commentary should remain on the topic of the drivers or kernel issue, otherwise I will close the thread.

1 Like

It was to no avail.
Your command, on the other hand, has now ensured that I can change drivers.
So I tried with Nvidia driver 470 to upgrade to kernel 5.11.0-34 which resulted in the same problem: black screen.
Then I tried with the nouveau driver but the problem persists.
So my previous thinking of changing to the nouveau driver is not a solution.
I have to get stuck at kernel 5.11.0-27

1 Like

At least you are able to switch Graphics drivers. In the meantime, the ZorinGroup is alerted to the fault in the 5.11.0-34 kernel. We can only await their response on the matter.


Friendly thanks.
Is there a way to remove the kernel 5.11.0-34 from the boot list?

1 Like

Yes, you can remove the kernel

sudo apt remove linux-headers-5.11.0-34

sudo apt autoremove

Don't forget to apt-mark hold the -27 until a fix is released.

1 Like