Resolving Login Loop issues ... should they occur!

Have found another potential cause to this problem - corrupt files. I booted a recent install of Zorin Education 15.1 on works Notebook and had login loop. Started in Advanced | Safe mode and ran FSCK - it could not run automatically, stated it would need to run manually.
So at the root prompt you type:
fsck /dev/sda1

This is assuming there is only one hard drive in the machine - you would of course put the device label according to which drive Zorin is on.
fsck runs and reports file errors in inodes and asks if you want to repair - well yes, you do obviously! Enter ‘y’ for any other prompts - it will tell you when you have finished. On completion of the task you will be returned to the safe mode options menu - don’t select ‘RESUME’ - turn off the machine and power up - problem solved! :grin:

The ‘de facto’ solution usually is to boot into advanced | recovery mode then from the recovery memory launch ‘root’ (terminal) then enter:
mount -n -o remount,rw /
then press Enter.
passwd your_username
then enter new password, shutdown and reboot.

If this does not work, and if you have Timeshift installed (can’t remember if Zorin includes this) then boot from live DVD/memory stick and point to where the snapshots are held and see if that works. If it doesn’t try one of the following 3 options (acknowledgements to … -loop.html? )

Method #1 Fix Ubuntu login screen loop

The first is quite simple. The file is located under the current user’s home directory. All you will have to do is change the owner of .Xauthority file.

Step 1 - At login time, use Ctrl+Alt+F3 to switch and access the command line interface mode.

Step 2 - Login into the shell using your username and your password. In this case, username will be your username you set when you installed Ubuntu.

Step 3 - Once logged in, now run ls -lah to view list directory contents. Look for the line that ends with .Xauthority
ls -lah-rw------- 1 root root 53 Nov 29 10:19 .Xauthority

Step 4 - You need to do chown. Type and run the following command :
sudo chown username:username .Xauthority
Now reboot and see if you can log in - if not:

Step 5 - If it does not work, try renaming.
mv .Xauthority .Xauthority.bak
Now reboot and try re-logging in.

Method #2 How to Fix Ubuntu login screen loop

Step 1 - Run ls -ld /tmp. Check for the first 10 letters in the left: they should read exactly so: drwxrwxrwt
# ls -ld /tmpdrwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp

Step 2 - You may need to changing permission. Run the command below :
sudo chmod a+wt /tmp

Method #3 How to Fix Ubuntu login screen loop

If even both did not work for you, try the last one! Please make sure you are connected to active internet. Check this out!

Step 1 - Uninstall and reinstall Ubuntu lightdm. Run the following:
sudo apt-get purge lightdmsudo apt-get install lightdmdpkg-reconfigure lightdm

Step 2 - Once reconfigured, now reboot.

[I have modified the instructions as it is not clear at which point you become ‘root’ using the ‘sudo’ command - if the last element of a terminal prompt is ‘#’ then you are in the terminal as ‘root’ with elevated privileges. If the last element of the command prompt is ‘$’ you are a standard user, and not ‘root’. I have written this tutorial experiencing just this and used Method 1 which solved the issue for me in FerenOS]

1 Like

A post was split to a new topic: Login issue