The problem with Zorin OS 16.2 and installing from USB memory stick on 4K monitors

History I forgot to mention in that thread that I had to switch off Intel SGX (Software Guard Extensions) in UEFI/BIOS on my Dell XPS 13 9370 as well as secure boot before installing, otherwise installing Zorin (any of 16.X) would not work, thought I would mention that also.

A couple of days ago I downloaded and tried Zorin Core 16.2 r1 and the problem with 4K monitors still stops the installer from moving on after selecting what to install. The Zorin 16.1 installer (which ISO I kept on my FTP-server just in case) works just fine and installs without problems. 16.1 then upgrades to 16.2 during apt-get upgrade after installing so it is still manageable but a fix for the 16.2 installer would really be welcome. I read that 16.2 can install on computers with 4K-screens if you connect an external monitor with resolution 1920x1080 to it (before, and use that) during installation, but this workaround is not accessible for everyone either, like having Zorin 16.1 saved somewhere for a rainy day.

Will this "4K-screen-and-zorin-installation-from-usb-problem" be fixed before the next version of Zorin is released? Keep up the good work everybody

1 Like

It'll surely be done.
The problem with the iso V2 is maybe a newer kernel

No, it is clearly not a kernel problem since it is only Zorins 16.2 installer(-s if we count both releases of them) that behaves this way. Latest Mint, Ubuntu and Pop-OS, to mention three recent I tried on my Dell XPS 13 9370, does not halt on 4K screens when installing from USB. Thankfully I could upgrade to 16.2 from Zorin 16.1 (since I have it saved) but I want this problem fixed.

What drivers are you using? ie is it an intel board, amd, nvidia, are you launching with nvidia latest drivers ect, and i suggest trying the latest iso.

16.2 Pro x64 installed fine on my htpc (beelink n5095) hooked up-to a 4k tv over hdmi ~ its is the current iso not the rc1 candidate. But I had no issues with install.

instead of hooking up a second monitor - try hitting Tab at the install selection "Try Zorin xxxx"
at the end of the line after splash --- add

that should place it in 1280x1024x24 a widely compatible mode for 4k and larger displays (yes this is the old school way but works)

you can also try
set gfxmode=1280x1024x32,1024x768x32,auto

1 Like

Dell XPS 13 9370 (2018) is listed as compatible with Linux and runs great on Zorin 16.2 as well (after upgrading from 16.1 via apt-get upgrade). Intel CPU and chipsets, nothing proprietary installed, just what the kernel offers runs on it. Same is true for all recent Mint releases etc. It is only Zorin 16.2 (both released ISO:s) that halts during installation which is why I posted concerning this installation problem originally about the first ISO and this second time about the r1-ISO.

I will check this the next time I reinstall for the sake of trying things out. This is purely a Zorin 16.2 installer problem so I appreciate this input. I prefer Zorin for my every day use which is also why I take the time to point these problems out.

Edit: I have all the latest BIOS/UEFI and firmwares flashed but I doubt any of this is the issue, Zorin 16.1 and Mint should have halted during installation as well if this was the case.

I have found with newer displays especially 4k the display themselves needs a driver that has yet to be compiled into linux and it causes issues as the monitor doesn't get identified and causes the system to freeze or not work with all modes.
see this thread:

I did find this post which may help as it sounds similar to your issue.

I have read the second link but not the first one, thanks.

However, if it is a driver problem, why can I install Zorin 16.1, then upgrade to 16.2 via apt-get upgrade, and with both versions of Zorin, change my resolution to whatever I want, including 4K? It is only when I try to install 16.2 (edit: tried both released ISO:s) that this problem with the halting installation occur.

Edit: Ubuntu, Mint and Pop installs without problems as well, like Zorin 16.1 does.

Because the when upgrading the online repos are accessed including ubuntu's latest driver and firmware repo and a system device poll and driver request is taken, when installing from the downloaded image its using the last stable build - it also doesn't include every driver available on the iso as it would be gigantic to include all drivers, firmware and dkms for every device out there, so the iso includes a number of drivers to be the most compatible for a wide range of devices. Windows does this as well which is why upon fist boot you see devices such as generic vga, generic hid, and then windows update downloads the drivers. Different distros may include different packs based on the toolkits used to build them the kernel version, dkms installed, ect.

Another issue i find with this, is odd or customized wifi drivers esp broadcom, the wifi doesn't work even though it looks like the iso has the right package, but hooking up a cellphone as a usb hotspot and running an update will install the drivers, and its because the oem asus ect customized the chipset, and specific firmware is needed for the exact laptop/netbook -

1 Like

That is a great explanation of the driver issue, thank you for taking the time. Also, I realize in retrospect, I am also thankful to myself for taking the time to look for such a forgiving laptop which gives me so few challenges to deal with running different distributions. Looking forward to future Zorin releases.

I tried to press tab at all the install selections but neither of the available options went to a console where I could add the lines you mention. Pressing Tab did not do a thing at all. Am I pressing the wrong button?

Try the esc key if using EFI boot.
If using Legacy (MBR), boot, hold down the Left Shift Key while booting up, instead.

Pressing e (not esc, tried that but it just aborted the bootup) allowed me to add the lines @seanhinkley mentioned but both set of lines I added (tried both at separate times) made no difference. The installer halted anyway. I think I will just have to wait for the next ISO/installer.

AH... You are on Live USB, not an installed system. Yes, sorry. You are correct, in that case tap the e key to enter the editor.

I actually do think this is likely, due to a variety of bugs and subsequent patches that are known from the Ubuntu 20.04 initial release that are not present in Ubuntu 22.04.


I just want to let everybody know that the Zorin OS 16.3 (Core) ISO works just fine when installing from USB for me. The problems I had with the 16.2- and 16.2r1-installers are not present in 16.3 when installing on my Dell XPS 13 9370 (2018).

This also applies as a solution to this (my earlier) thread:

Job well done everyone involved in developing Zorin 16.3.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.