Solution for black screen bug in Zorin 16 install: For Dell XPS with hybrid gpu touch screen (intel hd) this is how you overcome the black screen after grub

This problem does not occur on the latest Zorin OS 15, only on Zorin OS 16 beta (same method to create bootable usb) - rufus.

I had windows on AHCI from Intel RST (Raid) by using this solution first - Switch Windows 10 from RAID/IDE to AHCI - Knowledgebase / Microsoft Windows - Critical Technology Solutions - Helpdesk

Secure boot mode is enabled (no change)
UEFI mode as standard

You need a second screen for this to work. It will simply hang if you use your main laptop display (mine is 4k).

When you get to grub loader (from your bootable usb),press Fn and F8 (the screen switching key) which will switch your display to a second screen (I have a dell 1080p external screen connected via hdmi).

Once you can see your laptop screen on your external display - install as usual.

I also had to force grub from my 4k resolution down to 1280x1024 by modifying /etc/default/grub and adjusting the line to GRUB_GFXMODE=1280x1024. Problem solved.

Installation will then launch succesfully. If this step is not taken and you attempt to use your "internal" laptop screen, you will be met with a black screen and it will simply hang. CTRL + Alt + Del will reset your laptop but you won't get any further.

1 Like

Can anyone explain how to do this? I'm trying to install Zorin 16 Pro on my Dell precision laptop which is 4K - cannot get past the black screen. Tried the secon monitor trick with no luck...

Thanks

You may try the nomodeset option, first.
Before we can explore that, must ask: Do you have Nividia and Intel graphics or just Nvidia?

If you have Nvidia and intel, then when you boot the LiveUSB and see the Grub Menu (Try or install Zorin), tap either the tab key or the e key to edit the rub configuration.
This should open the editor and you will see lots of text. Scan Read until you see "quiet splash", in quotes just as I typed it here.
Type nomodeset into those quotes to make it:
"quiet splash nomodeset"

Then proceed to boot normally.

This is the kind of garbage that keeps Linux for geeks and not main stream. The rest of us are stuck with Microsoft or worse Apple. Many of us don't have a second monitor, one person even disconnected their 4k screen inside their laptop to get Zorin 16 to install and work. 4K screens have been around for a long time on laptops, mine is 4 years old. I have viewed many videos on Zorin and it looks amazing but there is no way I will ever get it running on my Dell Inspiron 7586 due to that fact you have to be a scientist to install it. I am 65 and just need it to install like MS or Apple OS.

I cannot count on both hands and feet how often I ran into issues with installing things on Windows that failed. And taking the error "This application has performed an illegal operation 0x000024x" off to find a solution made me not only not feel like a scientist, but not even a simpleton.

It is important to remember that the vast majority of users install Zorin OS without problems. Occasionally, as with any OS, someone will run into trouble.
That is why the forum is here: Not to force you to be a geek or scientist, but to work through the troubles if we are able, as best we can.

I have tried to install Zorin and other distros on at least three computers with no success. I have installed Windows a hundred time all with no issues over the last 20 years + since Windows 3. So our experiences differ. I came on here looking for a "One last Attempt" at a simple solution because I want to get away from Microsoft. Every time I try I just run into a brick wall I am afraid. I would buy a Zorin laptop but what happens when you want to upgrade, OH you have to be a scientist to upgrade.

The ZorinGroup is hot in development of a Direct Upgrade option in order to ease moving to the next Release of Zorin OS without a full reinstallation.

In the meantime, why not start a thread on your specific issue to see if we can help? We may fail, too. We may succeed. But our combined experiences may prove helpful.

You are very kind but this thread is my issue and always is, blank screen after install. I don't have a second monitor so the solutions I have found wont work for me. Having to have a second monitor or dissect your laptop are not viable for me (and shouldn't be for anyone). My laptop is a Dell Inspiron 7586 with a 4k screen. I need the 4K for my eyes. I write, so I need crispy text when working for hours. I have already tried all the other stuff like legacy boot and a myriad of other Bios changes to no avail. So I think it is time to give up until I can buy a Zorin or other linux laptop off the shelf.

If you hold the d button down during boot, does the machine run through the self-tests?