Uefi/legacy dell and acer

dell vostro intel celeron 1000 m 2gb ram

so i tried installing zorin os on this laptop that is someone elses , it worked the first time. when i tried installing it on the first try it booted up after many lines going down the screen and cause of that i went to eat, after i finished it booted up and i ended up deleting all the partitions and creating one partition and after that it brought me to the religion selection menu and then suddenly some message pop up saying something failed and needs to reboot when i rebooted i removed the pen drive and learnt my lesson. so in the 2nd try the lines again came up but this time something failed and i cant read it properly because it keeps flashing.

so after 28 tries it broke my pen drive and now it can only be formatted into fat32 or it wont even show up. this is a 130 gb pen drive.

so tried installing windows 10 on it with gpt partition scheme because mbr wont allow fat32 format option on rufus and changed the laptops bios to uefi but it wont even boot . it just shows some white line and reboots.

pls someone help install zorin or something on this damn laptop with a fat32 130 pen drive since this is the only drive i have, i already spen 2 weeks on this and you guys are the only hope left

also i forgot there was a time when installing zorin it showed some syslinux failed or missing something or some file missing

Does the laptop have a DVD Drive? A .ISO burnt to DVD seems to work better that a USB stick in my experience. Perhaps borrow one (USB to DVD drive) if not

1 Like

In order to boot from EFI, there must be an EFI partition:

This is not a ZorinOS or a Linux or a Windows thing; it is how EFI and MBR differentiate. It is a hardware thing.
Here is a pretty good guide I looked up that has screenshots for step by step EFI boot partition creation:

Once that is set up, the Installer should have no trouble. With Zorin OS installed (or Windows if you prefer), you can plug in the USB and wipe and reformat it.

thanks for the help

@finston yes the laptop does have a DVD drive and i have a 4gb DVD but I don't have any device that has a DVD drive slot

@Aravisian thanks for your suggestion but i am pretty much close to a newbie but i am trying to get experienced from doing this sort of things as i am very interested in software and tech stuff but unfortunately i don't get what you are saying as i am just trying to boot zorin os os on this 2013 laptop that doesn't have any os installed on it.
** The laptop bios allows me to switch from legacy to uefi mode.**
i only have a fat 32 128gb usb that cant be formatted to ntfs file system

looking forward for suggestions :grin:

Originally, MBR was used in computers- The Master Boot Record. The MBR could only support up to Four Bootable Partitions. A partition is a Section of the hard drive that is reserved for an Operating system or Data Storage. In reality, you can create and use a partition pretty much however you want... But the common usage is to install an Operating System on it.

Since Windows is (By Far...) the dominant O.S., manufacturers began to offer a partition of sold computers that contained a Recovery Section- for restoring a computer to Factory Condition. System Restore. This is because... bunch of Windows users... what with the unchecked installations, viruses and whatnot...
With more and more advanced options in recovery, it became clear that a better method than MBR was needed. Something that can offer more than Four Bootable Partitions and manage more data flow faster.
EFI was introduced (Extensible Firmware Interface) to meet this demand. UEFI is Unified Extensible Firmware Interface.
A computer that has a blank hard drive lacks an EFI partition which is needed for the Zorin OS installer to know where to place GRUB (GRand Unified Bootloader). Without Grub, the OS cannot fully install and would not be able to Boot after installing.
Your first step must be to use a partition Manager (You can use the one provided in the Try Zorin USB) to create a 512 megabyte EFI partition as outlined here:

What were the results of setting BIOS to Legacy and then installing Zorin?

That is fine - the filing system NTFS is strictly for Windows. :wink:

thanks you so much for your help and for the explanation

actually i tried to search for live bootable usb partition manager since that laptop has a blank hard drive with unallocated space but i couldn't find one

so you are saying i should boot into zorin setup and select try zorin os and use the partition manager to create an efi partition?

dell vostro
intel celeron 1000m
blank hard drive 320 gb
legacy bios
2gb ram

What were the results of setting BIOS to Legacy and then installing Zorin?

some white line appears and says some linuxsys failed

wait for about 5 to 10 min i will get back to you i intalled a new zorin copy and this time a new tool i am going to try again and tell you the results

so i encountered a problem with my pen drive so i will get back to after 1 hour

Ok. I will not be around at that time, perhaps others will. I may be back in about 5 or six hours.

1 Like

yeah okay i managed to fix it using rufus

1 Like

12 posts were merged into an existing topic: Zorin os 16 usb not showing as a boot option

good news turns out his father was not in contact with the positive case so now i have access to the laptop

because I now have access to the old dell laptop we will continue discussing about it on this forum

And we will be discussing the uefi based Acer laptop on this forum - Zorin os 16 usb not showing as a boot option - Installing Zorin OS - Zorin Forum

for people who are confused before i was talking about the old dell laptop but because of issue I wasn't able to get my hands on it so instead i started talking about another laptop (acer) that I already have until i get my hands on it. So now i have access to the old dell laptop

@aravisian I fear this thread has got confused and complicated by OP cross linking and discussion of two issues affecting: 1) Dell laptop installing Z15.3 Education, then 2) Acer laptop installing Z16 Core Beta (posts 13 to 25). That also appears as new thread Zorin os 16 usb not showing as a boot option

Do you think it would aid clarity to move posts 13 to 25 above to that thread?
And renaming this one omitting "Acer"

@Layyan Have you had a look at this tutorial: Before you install

1 Like

bad news when i went to get the laptop which was at this persons place i found out his father was in contact with a positive case of you know what

so for now this discussion is closed since i have no way of retrieving the laptop

i will try to install on my uefi based laptop to practice😉

Yes. I got confused several times in the course of it. :stuck_out_tongue:

For this laptop:
dell vostro intel celeron 1000m blank hard drive 320 gb legacy bios 2gb ram
You do not need a UEFI partition. If the BIOS is set to Legacy, ensure that when you boot the USB, you select the USB name as is, not a USB listed as UEFI (I have made this mistake, myself).

already did that but some lines apprar and 10 min later it fails

also i dont know how to install zorin os on the uefi baed acer laptop
i tried many times and in many ways using different tools but it only boots back into windows
i already changed boot options and disabled fast boot