Zorin 16 Pro and D6000 docking station - not friends?

I am having some problems making my docking station work well with Zorin OS 16 Pro.
The Dock is Dell D6000 and my laptop is Acer 5750G
If I leave the docking station plugged in and then start the computer, I only see a dark screen, and nothing else. No keys combination work, even though I unplug the docking station
If I start the laptop and then plug in the docking station then it works somehow:

  • if I press Win + P, then the image goes live on one external monitor and everything else is dead. I need to force the shut down by pressing the power button
  • if I go to Display settings, I see one monitor, I slightly adjust the position of it and press Apply. Then I press Win + P, it detects all my monitors and the docking station works.
    But the problem is when I shutdown, because it gets stuck at killing xorg server and it does not shutdown ever.

Now, I have tried with both Nvidia video card drivers and zorin's drivers
The docking has the latest firmware installed.

What can I do?
I mention that on Windows 11 the docking station works without problems and I thought since Zorin OS is based on Ubuntu 20.04 it should work without problems

P.S. Proof the docking works with ubuntu:

Zorin OS 16 Pro
Dual boot (MBR) with Windows 11

Inxi details:


System: Kernel: 5.11.0-40-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.11.0-40-generic root=UUID=30c05268-443f-4df0-869d-4f135856e1eb ro quiet
splash vt.handoff=7
Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal
Machine: Type: Laptop System: Acer product: Aspire 5750G v: V1.21 serial: Chassis: type: 10 v: 1.21
Mobo: Acer model: JE50_HR serial: BIOS: Acer v: 1.21 date: 08/09/2012
Battery: ID-1: BAT0 charge: 14.3 Wh condition: 14.3/47.5 Wh (30%) volts: 11.8/10.8 model: PANASONIC Li_Ion_4000mA
type: Li-ion serial: status: Full
CPU: Topology: Quad Core model: Intel Core i7-2670QM bits: 64 type: MT MCP arch: Sandy Bridge family: 6
model-id: 2A (42) stepping: 7 microcode: 2F L2 cache: 6144 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 35121
Speed: 818 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 818 2: 798 3: 833 4: 798 5: 834 6: 854 7: 798 8: 798
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Acer Incorporated ALI driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:0116
Device-2: NVIDIA GF108M [GeForce GT 540M] vendor: Acer Incorporated ALI driver: nvidia v: 390.144 bus ID: 01:00.0
chip ID: 10de:0df4
Display: x11 server: X.Org 1.20.11 driver: modesetting,nouveau,nvidia unloaded: fbdev,vesa compositor: gnome-shell
resolution: 1920x1080~60Hz, 1920x1080~60Hz, 1366x768~60Hz
OpenGL: renderer: GeForce GT 540M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.144 direct render: Yes
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20
Device-2: NVIDIA GF108 High Definition Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:0bea
Device-3: DisplayLink type: USB driver: cdc_ncm,snd-usb-audio,usbfs bus ID: 2-1.4.1:9 chip ID: 17e9:6006
Sound Server: ALSA v: k5.11.0-40-generic
Network: Device-1: Broadcom and subsidiaries NetLink BCM57785 Gigabit Ethernet PCIe vendor: Acer Incorporated ALI
driver: tg3 v: kernel port: 2000 bus ID: 02:00.0 chip ID: 14e4:16b5
IF: enp2s0f0 state: down mac:
Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter vendor: Foxconn T77H167.00 driver: ath9k v: kernel
port: 2000 bus ID: 03:00.0 chip ID: 168c:002e
IF: wlp3s0 state: up mac:
IF-ID-1: enx9cebe853627a state: down mac:
Drives: Local Storage: total: 447.13 GiB used: 22.43 GiB (5.0%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: B1E1 scheme: MBR
Partition: ID-1: / raw size: 41.99 GiB size: 41.08 GiB (97.83%) used: 22.43 GiB (54.6%) fs: ext4 dev: /dev/sda4
Sensors: System Temperatures: cpu: 69.0 C mobo: N/A gpu: nvidia temp: 69 C
Fan Speeds (RPM): N/A
Info: Processes: 272 Uptime: 7m Memory: 7.62 GiB used: 1.89 GiB (24.8%) Init: systemd v: 245 runlevel: 5 Compilers:
gcc: 9.3.0 alt: 9 Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Hi and welcome to the forum :slight_smile:

Have you checked this page?

Yes. I have the latest drivers installed, but no difference.
Thank you

Ok, the time to invoke our master volunteer :crown:

What is the output from

sudo lshw -c video

Do you have any Kernel parameters added to your grub file?
If not, you may try

sudo nano /etc/default/grub

Find the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and change it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
ctrl+x to exit, then the y key to say yes to save. Then the enter key to save as current configuration.

Reboot and test...

If no good, try:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ide=nodma apm=off acpi=off vga=normal noapic nolapic"

1 Like

output of sudo lshw -c video


description: VGA compatible controller
product: GF108M [GeForce GT 540M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:45 memory:d0000000-d0ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:2000(size=128) memory:d1080000-d10fffff
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:37 memory:d1400000-d17fffff memory:c0000000-cfffffff ioport:3000(size=64) memory:c0000-dffff

And I did not have any kernel parameters. I will try now your suggestions

Oof... pretty old card...

1 Like

I have tried you 2 suggestions, but if I leave the docking station plugged in, I get a black screen on all the displays(integrated one + external monitors).
Also, I am using the latest Nvidia drivers (390) for my video card.
I will try also with driver 340

Legacy, almost a museum piece :stuck_out_tongue:

Is that driver 390.144 ? That is the only driver that will work with the 5.11 kernel

Release Highlights:

Fixed a bug where vkCreateSwapchain could cause the X Server to crash when an invalid imageFormat was provided.
Fixed a driver installation failure on Linux kernel 5.11 release candidates, where the NVIDIA kernel module failed to build with error "fatal error: asm/kmap_types.h: No such file or directory".

Yes. That is the driver.
I tried to install the 340 one, but it gave me some error. I might need to do some cleanup I suppose

Maybe because it's probably using your intel gpu instead of the nvidia one. @Aravisian


Or struggling to switch?
Maybe nomodeset?

i am not familiar with dual graphics, i have 1 card in my notebook. My wife has 2 but they work out of the box. I don't know if he can switch off the intel so the nvidia will take everything over.

1 Like

Now which OS you sneaked into her laptop? :sunglasses:

Pop! OS, she said she did not care as long as it is not Microsoft Windows. She got mad after the MS updates killed here wifi card. Pop! OS discovered both cards (AMD Radeon HD 7670M and the Intel 4000), today she upgraded to kernel 5.15.5 and still working. Machine is 8 years old.

1 Like

Such anecdote makes me wonder if it is more reasonable to advise people with a similar setup to go for POP, not Zorin.
I routinely advise people with 2GB RAM or less to go for MXLinux or Linux LIte.

The laptop really has no issues running Pop! OS, runs pretty smooth. Her specs

Intel Core i7 3632QM
8 GB Ram
17.3 inch 
Resolution 1600x900
AMD Radeon HD 7670M + Intel HD 4000 GPU
750 GB HDD <- Replaced with a Samsung EVO 870 500 GB

The story continues like this:
After more searching on the internet I found the a patched xorg server and installed it (DisplayLink XServer Patch 20.04 | Synaptics) which led to a system break. I could not log on to Zorin.
After more searching, and booting in emergency/rescue mode , uninstalled old xorg, and resintalled it, then the system booted up normally, and the docking station works as expected.
Also in Additional drivers I see that now is using X.org.X server -- Nouveau display driver from xserver-xorg-vide-nouveau (instead of Nvidia driver which it used before)

As a conclusion, I do not know what exactly made it work, but now it works, it recognizes my monitors if the docking station si already plugged in when booting.
thank you also for your help and ideas


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.