Zorin 17 installer insists on tablet mode

I've had Zorin 16 installed and running (but for its refusal to hold on to whatever setting keeps the touchpad operational) for quite awhile....on a Lenovo Flex 3 laptop. (This computer came with Windows 10 and was what I used for some of my initial forays into Linux. As a result, in addition to Zorin 16 it still has Windows and also has MX Linux installed...no lectures, please :smile:). The "Flex" here is the laptop's feature that lets you fold the screen back against the bottom and use it as a tablet. I did not buy this for that reason and, in fact, have never used it that way. When in Windows 10, the screen is locked in the horizontal, laptop position. Same with MX Linux...rotating the device 90 degrees either way will not change the orientation of the screen.

Not so with Zorin, it appears. I was going to wait for the upgrade from 16 to 17 but I got restless yesterday and decided to do a clean install. When I booted to the USB and selected Try/Install, the installer appeared "on its side," 90 degrees to the horizontal view. No movement of the computer would make it flip to horizontal. Once I got to where there were some Cancel buttons, I could bail out.

Curiosity suitable aroused, however...I booted up the already-installed Zorin 16 and rotated the computer (which, again, I never do). Son of a gun if the screen didn't flip to tablet mode and, as with the 17 installer, refuse to re-orient itself other than to flip 180 degrees to go "tablet mode" in the other direction. As with the 17 installer, my only recourse was to shut down.

What is it that Zorin 16 & the 17 installer are seeing (and being controlled by) that neither Windows 10 nor MX Linux on the same device pay any attention to?

Have you checked this thread:

I had not...so thanks for pointing me to it.


My Zorin menu structure doesn't track exactly with yours: Settings does not offer "Devices" on the next level (a search for Devices produced nothing). Instead, the Settings menu directly offers "Displays," under which I do not find a setting for Orientation or Display Orientation (only Resolution and Fractional Scaling, along with a separate tab for Night Light).

When I tried the terminal command, I was not sure if the actual command included the ellipses seen in your text, so I ran it both ways....and neither iio-s nor iio-s... could be found. Checking within the tutorial I saw that the full command ended with iio-sensor-proxy and I ran that.

And that seems to have cured the problem at least with my installed 16...so thanks again! Now.....I'll resume the try for a fresh install of 17 Core.


After fixing the screen rotation in my installed Zorin 16, I attempted two more installs of Zorin 17....both failed.

First (and I guess you knew this but it didn't dawn on me), it didn't matter if the screen rotation in 16 was fixed because I was going to boot up 17 Live from the USB and, once again, have the same problem. So, on both attempts at installing 17 I just cocked my head and bulled through the process....only to have both fail (the installations were complete and I could select Zorin 17 from the updated grub menu...but after the initial flash of info at the top of the screen (in microscopic type!) the screen went to black and nothing else ever happened. I waited many minutes.

So I've decided to go back to my USB that still contains Zorin 16 and reinstall that (which was successful...and BTW, the installer for 16 did not have the problem with screen orientation, nor did it oh so many months ago when I first installed 16).

I will patiently await the option to upgrade to 17 from within 16.

At this time, I am not confident that an upgrade to Zorin OS 17 will resolve your issue.
Change Screen Rotation in Wayland/Weston Desktop - Display.

What you've directed me to is a bit above my pay grade, sir! :slightly_smiling_face:

Recap: Zorin OS 16 installs fine (even the re-install today) and the installer for 16 does not turn itself sideways like the installer for 17 (in case you were still inclined to blame the computer for spurious signals).

But two attempts at fresh installs of 17 (just surrendering to the screen rotation and getting on with it best I could) ultimately failed when, after the start of bootup via the grub menu, the screen went to black after the first flash of type at the top of the screen....and nothing more ever happened. So....my challenge with Zorin OS 17 is not so much that the screen appears rotated to tablet mode and can't be spun to laptop mode but, rather, that the new version won't even start up!

I tried a netsearch on installing Ubuntu 22.04 on the Lenovo Flex 3 and came up with quite a few people seeking support but without solutions.
Is your drive a soldered in eMMc?

My drive is whatever the Lenovo Flex 3 came with from the factory (and I don't mean that as snarky as it may sound). According to the sticker on the bottom of the unit, the computer is actually a Flex 3-1120 with a model number of 80LX0026US and date of manufacture of August 15, 2004. File Explorer says the HDD has a capacity of 149 GB.

That's interesting about the reports of problems installing Ubuntu 22.04 on a Flex 3...because I have Kubuntu 20.04 LTS on a completely different laptop (a Lenovo x131e, a computer built especially rugged for the Education market) and a few months ago I could not complete a fresh install of 22.04 LTS into the same partition (but for different reasons) and, similarly, no solutions from the Forum staff (though, in fairness, they thought it was connected to some other user problems and they wanted to forward some specific info to the developers but 1] the process would have required a lot of hand-holding for me and 2] the error messages I was receiving indicated some risk of a total wipe-out, so I declined...and they understood).

While many users experience no trouble installing on eMMC, it seems pretty hit and miss.
According to Lenovo; the standard is eMMc:

However, it specifies "some" which means that buyer choice at purchase applies;

eMMc drives usually are 32 or 64gigabytes in size whereas you show a 150gig drive.

Have you tested if Zorin OS 16 will install?

Hehehe...you might want to go back up through this thread! :laughing: (I'm sure it's hard to keep track of all the conversations you participate in).

This very partition on this Flex 3's HDD has had Zorin OS 16 installed for many months (and, as I noted, at the time of that install, the installer did not lay the screen over to tablet mode like 17 does). Then, after my two failed attempts at an install of 17, I reported that I went back to 16 (still had the USB), installer again did NOT flop the screen to tablet mode and installation was successful.

Very. It is not unusual for me to repeat something or miss something.
In this case, I posted while distracted by something else: I reallu should have been 100% aware that you have been using 16 considering how thoroughly you covered that...

I have noted a variety of irregularities with the 17 installer that relate to many different kinds of hardware from Macbooks to certain ssd's.

Excuse my ignorance here but....are there channels through which this kind of info is reported to the Zorin developers?

Several, including launchpad, github - but the one in use on this forum is the Feedback sub-forum.

That said; I have also escalated to the ZorinGroup the noted issues reported about general lag and installation troubles in the moderator forum.

Different things may have different solutions; it may take some time to suss out causes and get things patched.

These are more side comments here: you are not alone and things are being reviewed. But this does not mean that this thread should stop focusing on your issue.
If we can find a solution to your stated issue; this can help toward looking at other installation troubles if not help other users of Lenovo.
I am not sure what is different from Zorin OS 16 to Zorin OS 17 that is affecting your specific machine at the moment. This will take more research. Part of my having made the comment is probably due to frustration at not knowing what is causing your trouble and having a solution at the ready.

One of the first things I would suggest we try is actually rolling your kernel back to an earlier version On Zorin OS 17.
This can be done with one command in the terminal on an installed system, but doing so prior to installation is much trickier.

Well, if your assessment is it's "much trickier" I hope I'm not completely overwhelmed! But I'm intrigued....I think.

@Aravisian, am I pretty much stuck with the way things are? Is waiting (more "coming weeks") for the upgrade the best approach? Or was there anything else you wanted me to do?

The Zorin OS 16 to 17 upgrade has arrived:

I'm sorry for the delay. What I do is I keep tabs open that I need to keep track of. While working on a tricky thing of my own, it resulted in a series of crashes that resulted in me losing all my open tabs.
(I could have gone through the extensive history and restored some but... I was tired and irritable at that point).

There is more than one way to do what is suggested:

  • Change the kernel in the Zorin OS 17 .iso and then re-wrap the .iso with the new kernel. This is tricky and I do not recommend this approach.
  • Install Zorin OS 17, then immediately install the different kernel prior to rebooting into the new desktop. This is easy and definitely what I would try first.

The steps to do the second option would be to install Zorin OS normally.
Once it completes, it will tell you to reboot. Do so... Except monitor the screen and bap the esc or tab key as needed to reach the Grub Menu (necessary if single booting with no other OS. If you are dual booting, the Grub menu should show at every boot).
From the Grub Menu, select Advanced Options for Zorin.
From there, you can select a kernel to boot from or - that kernel on (Recovery). Select the first convenient (Recovery) option.
This will take you to the recovery menu.

You must first enable networking so arrow key down to the option to do so. Once networking is enabled granting you net access, back up to the recovery menu and arrow key down to Root - Drop to Prompt

In this, you must enter the terminal command to install the kernel you want. First, update your sources

sudo apt update

Install the kernel in use on Zorin OS 16.3:

sudo apt install linux-image-5.15.0-83-generic linux-headers-5.15.0-83-generic linux-modules-5.15.0-83-generic linux-modules-extra-5.15.0-83-generic

I believe the latest on 16.3 is actually -92 or something, but when I did an apt search on 16.3 for it, I only saw one for -91 so I opted for the -83 for safety.

Once the kernel is installed, reboot. Immediately enter the Grub menu again, and Advanced Options for Zorin. Select the option for Zorin on 5.15... to boot from.
Once booted into the desktop, you will need to follow the steps here:

To ensure you default boot into the earlier working kernel.

I see that the upgrade is now available...but for testing (not ready for production computers). So I wouldn't be jumping on this train just yet.

But are you saying I should do the upgrade? You said "The steps to do the second option would be to install Zorin OS normally." I'm just looking for clarity on what is "normally" in this case, considering the problem I have with the 17 installer going into tablet mode.

And if the upgrade path should actually work, are you of the mind that a reversion to an earlier kernal would still be a good idea?

I suspect that the upgrade is unlikely to create a solution if the solution is an earlier kernel. However, a later kernel may have been repaired from the one that comes with the Zorin OS 17 .iso, as well.

I believe that the upgrade is safe. I am not of the mind it will create a solution but I would be happy to stand corrected.

Follow the normal install procedures up to completion.

The one thing that the Zorin OS Upgrader can offer you is the ability to upgrade to Zorin OS 17 while retaining the working kernel. This means you would not need to enter into the Recovery Menu and install the kernel.
You could just roll back onto the existing installed kernel from the grub menu.
However... the upgrader is also a One Way Street. If anything goes wrong, you cannot run the upgrader in reverse to downgrade to Zorin OS 16.

I highly recommend checking up on all your back ups for personal data and files.

I went through the upgrade process, all the way though, including the reboot. And the good news I guess is that it didn't blow up or anything. The not-so-good news is that both lsb_release -a and Zorin>Settings>About still show me running 16.3

That's... weird.

If you boot using the grub menu, what kernel options are shown to boot from?