Zorin OS 15.3 64 bit: stability problem

Hi,
I installed zorin OS 15.3 64 bit with latest kernel 5.4.0-60-generic on PC with AMD CPU FX-8350 with asus SABERTOOTH 990FX. The same PC does not have any problem with windows 10 64 bit. Now I’m experimenting a stability problem. Sometimes, without any apparent reason, the systems gets stuck and I have to manually power off it. I already tested the RAM and the drives and there are not any problem.
Any idea?

@erotavlas Hi, sounds same as Zorin occasionally freezing. See this:

Also. Software updater updated my kernel to 5.4.0-62 yesterday if I was not mistaken.
Which version of Zorin do you have? e.g. Core, Lite etc.

Also worth checking Software Updater -> Settings -> Additional Drivers, if you haven’t done so already.
Also check your updater settings before checking above: Software Updater settings

Hi,
I’m sorry for my late reply. The problem is still there with kernel 5.4.0-66-generic. I have zorin education lite (xfce).
Now, since I have an old geforce 8500 gt, I tried to enable proprietary drivers nvidia 340-108. My software updater setting is as @carmar suggested.

Can you post the output of inxi -t cm ?

inxi -t cm
Processes: CPU: % used - top 5 active
           1: cpu: 85.1% command: ..wcgrid_mcm1_map_7.43_x86_64-pc-linux-gnu pid: 1966
           2: cpu: 83.6% command: ..wcgrid_mcm1_map_7.43_x86_64-pc-linux-gnu pid: 1964
           3: cpu: 83.3% command: ..wcgrid_mcm1_map_7.43_x86_64-pc-linux-gnu pid: 1962
           4: cpu: 82.7% command: ..wcgrid_mcm1_map_7.43_x86_64-pc-linux-gnu pid: 1973
           5: cpu: 81.5% command: ..wcgrid_mcm1_map_7.43_x86_64-pc-linux-gnu pid: 1970
           Memory: MB / % used - Used/Total: 3531.1/7907.1MB - top 5 active
           1: mem: 710.24MB (8.9%) command: ..wcgrid_arp1_wrf_7.27_x86_64-pc-linux-gnu pid: 1977
           2: mem: 320.10MB (4.0%) command: firefox pid: 2741
           3: mem: 289.16MB (3.6%) command: brave pid: 2730
           4: mem: 283.22MB (3.5%) command: Telegram pid: 1755
           5: mem: 252.56MB (3.1%) command: Keybase pid: 2331

Note: after enabling nvidia drivers, the OS loses the start/application bar. I can access it by pressing start key in the keyboard, but it is not visible.

Are you using a crowdsourced computing program (BOINC etc)? When I search for “wcgrid_mcm1_map”, I get such results.
Here is what I have observed about Linux relative to Windows, the former seems to dedicate more resources to process intensive tasks than the latter. Perhaps this is because Linux itself uses less resources than Windows. @Aravisian would know better.

But as to your problem, if you shut down or limit the resources dedicated (typically such programs allow you to choose that) to your crowd computing program, your stability issues should go away. I am certain Linux is already dedicating more resources, in totality, to that program than Windows could have so you won’t be missing out by limiting the resources by your own choice.

Yes, I’m using BOINC since 2004. In particular, I’m using BOINC with this machine since 2012 and I never had any problem both with windows 7 and 10. The temperature of CPU is low about 40 °C.
I can try to leave 2 core free and I will let you, but I do not think it can be the source of the problem.
Do you know how to solve the issue with nvidia drivers?

Sorry. Other than my first post, I don’t know what else to recommend. I have already cited Aravisian, so he should be coming along soon with any thoughts he may have on that as well.

I am more Novice than you give me credit for, but I am leaning toward the same opinion as erotavlas.
I suspect kernel is too low.
There have been a variety of additions as well as patches to the kernel since 5.4.0 and since Zorin 15 is built off of Ubuntu 18.04, they are slower to reach us.
A bit of brutal honesty: The kernel version we see is only seen after extensive testing and after vetted patches specific to this build. Both Zorin and Canonical follow the philosophy that the “latest and greatest” is not really the greatest. Generally, I agree with this. This is in part because throwing the Latest kernel out to older machines is prone to more bug reports. Older machines don’t need all of that; the kernels that address that hardware is already in place.
But newer machines or even older machines that are running the Latest Software - Including Nvidia drivers or machines upgraded in Nvidia cards - are likelier to need the later kernel models. Really - We should be well above kernel 5.6.0 by now.
But since, while 18.04 is LTS, Ubuntu 21.04 is out, 20.04 is still in popular use and because Zorin 16 is in active development and due for release any day now, some of us users fall between the cracks- strangely enough even myself at the moment.
We are caught in that In-Between moment. Canonical is more likely to give priority to testing for 20.04 than to “old” 18.04; LTS notwithstanding. There is less testing for 18.04 on the kernels and updates are getting slower to come.

The ideal situation would be to Upgrade to Zorin 16, but it is not yet released. The next option is to wipe and reload to another distro, and that is not always a welcome idea.
This leaves upgrading the kernel - which requires not installing the Mainline kernel. Canonical (And therefor, trickles down to Zorin) releases kernels after testing, but also after adding Ubuntu Specific Patches and drivers - that is the Mainline kernel. There is no sugarcoating it- Usually that is fine but it is risky; sometimes it is not fine and I utterly annihilated my copy of Zorin 15.2 sometime back, merely by upgrading to 5.8.0. I lost everything and had to reinstall.

I wish this was one of my usual and shorter “Try this” posts. It’s just timing, is all. As it stands right now, we users are in a spot.
The sooner Zorin 16 is released, the better. And I highly recommend that everyone jumps on it when it is released and don’t wait.

In the meantime, upgrading the kernel to the highest one the machine can handle, then installing or reinstalling the Nvidia Drivers is probably the way to go. I cannot recommend a kernel offhand… it depends. The user, on their own, has the best bet of notching the kernel up, version by version until they get to one that works and Stop Right There. Leave the older last kernel on the machine (Do not sudo apt autoremove it) until using the newest working one for a while, just in case you need to roll it back.

1 Like

i have tried kernel 5.9.16 and kernel 5.10.16 for 1 week each. I’m not having any problems and it’s stable as usual. I want to try zorin 16 when it’s released.

1 Like

At the moment, I do not want to change the GNU/linux distribution. I chose zorin os thank to its user friendliness and similitary with windows.
I agree with @Aravisian, it could be a kernel problem and I hope to see zorin 16 based on ubuntu 20.04 as soon as possible.
In the meantime, I will try to install a not mainline kernel and I will report here the results.

Please see here:

Or here

Thank you, I usually use this utility.

1 Like

I installed that utility and checked it out- and need to point out a fair warning:
Technically, it will show and install Mainline Kernels. But this is only because Mainline Kernels are listed. It lists all available kernels and a person could easily install an Unsigned kernel if they do not check the details first.
This could also lead to a list of possible missing firmware, as well.

Great utility, but read all details when using.

Of course, the utility automatically downloads and installs the selected kernel and it is not different from wget -c && dpkg -i *.deb. If firmware and module are compatible, they will be compiled and installed.
Since zorin os 15.3 has support of virtualbox 5.2.x, I used the newest compatible kernel 5.7.x while virtualbox 6.1.x supports up to kernel 5.10.x. Later I will try to upgrade to the latest virtualbox.