Zorin Plymouth Boot Logo and Animation Disappeared

hey all, I am new to Zorin OS and trying out the new Beta 16. It is very slick and I like it so far. One odd thing is that the little Zorin logo and the animation right before the login screen shows up has disappeared. Now once I select Zorin from the grub bootloader, I get a black screen until the login screen shows up. Then everything seems to work normally. I have an Nvidia GTX 1070Ti graphics card and used the installer specifically designed with the proprietary drivers etc. Oddly enough, when I tried to boot that same install using the built-in Intel graphics provided on my motherboard, I could see the logo/animation. I've tried other steps i've read about in the forums in regards to the subject without any success. I tried using the "sudo update-alternatives --config default.plymouth" anyways and then "sudo update-initramfs -u" but again, no change. Perhaps the bootloader is somehow treating my install as standard and not the specific nvidia one? Maybe accidently booting the nvidia install with my Intel Graphics messed it up somehow? Any advice would be appreciate. Thanks!

Sounds like this.
@Storm expressed having a similar issue.
You may try adding the nomodeset parameter to grub to see if that stops Nvidia from controlling the graphics at boot.

I never get around to test it though, got caught up in stuff.

This stuff?
:smiley:

Yeah, gotta redo all the mime types icons, though it require more than recoloring. I have to clip (reverse) to make them transparent. Also got a long wish list from a user.

1 Like

I appreciate the suggestion but I unfortunately had already tried that flag and no change. In fact, I think the problem might be that the nvidia graphics card NEEDS to be in control from boot. I wonder if there are any specific flags grub is supposed to pass to tell kernel to use nvidia-specific display modes?

1 Like

I have been quite a busy bee

Have you tried this one: Zorin Splash Screen missing - #4 by Aravisian
In this thread it's mention to download the bootup from Pling.

wow cool, but what about MY needs?! :stuck_out_tongue: no but seriously that IS alot of work. are you one of the devs? if so, I can totally understand youd be pretty busy putting the finishing touches on the official release of 16 :smiley:

1 Like

You might try nvidia*-drm.modeset=0

Or try seeing a late KMS start.

No just a passion user :wink:

1 Like

I think this worked! although it still goes black right after grub for a good 5 or 6 seconds, then shows the pulsing logo and then the ZORIN animation and then into login screen. is that flag part of the default grub config for nvidia builds? I did sort of have to tinker manually with grub when I initially installed Zorin OS so maybe I used the wrong stuff. I don't suppose you could paste the stock grub menuentry for the nvidia build so I could compare? Thanks!

1 Like
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480