ZorinOS being laggy

I installed Zorin OS Core today. And it was laggy a bit from the start. Then it stopped and now it started again. When I’m in apps and when I scroll it laggs. Especially in Firefox. I reinstalled a fresh PC and I don’t have dual boot. My specs are:
Intel Core i5-6600
2x8GB DDR4 2133MHz RAM
3TB HDD
256GB SATA III SSD
GTX 1060 6GB GPU

When I had Windows there were no such lag. And my memory usage is anywhere from 4GB to 6GB and CPU usage from 20% to 40%. So that’s not the problem.

  1. Can you tell us what processes use most RAM, most CPU?
  2. Check Software Updater settings as well as Software Updater -> Settings -> Additional Drivers.
  3. You have just one GPU, correct? If you’re unsure, post output of lshw -c display

gnome-shell uses most RAM about 955 MiB
I checked those settings and its set to latest drivers, nvidia-driver-460 (proprietary, test)
I have one GPU, GTX 1060 6GB from MSI

EDIT: nvidia-driver-460 (proprietary, tested)

Can you provide the output of inxi -t cm? Since 4~5GB RAM is being used by other processes, do you mind closing them and just running the command with no other applications running?

Additionally, after checking your updater settings, check your Firefox version in Synaptic.

Apps also sometimes freeze and unfreeze. Output is:
Processes: CPU: % used - top 5 active
1: cpu: 53.4% command: Discord pid: 2147
2: cpu: 39.0% command: gnome-shell pid: 1151
3: cpu: 15.5% command: firefox pid: 1705
4: cpu: 9.0% command: Xorg pid: 959
5: cpu: 5.9% command: pulseaudio pid: 1160
Memory: MB / % used - Used/Total: 4604.8/15977.0MB - top 5 active
1: mem: 1130.32MB (7.0%) command: gnome-shell pid: 1151
2: mem: 775.96MB (4.8%) command: Discord pid: 2147
3: mem: 716.94MB (4.4%) command: firefox pid: 1922
4: mem: 698.66MB (4.3%) command: firefox pid: 1705
5: mem: 403.47MB (2.5%) command: firefox pid: 1992

And Firefox version is 85.0.1

I ran sudo apt-get update and sudo apt-get upgrade several times today

Can you terminate Discord and check Firefox lag (and any other application lags)?

I did and lag stopped. However I think it stopped even before I closed it.

1 Like

With your machine specs, even at 60% CPU, you should not be seeing lag like you are describing.
Did you confirm all lag stopped after terminating Discord?

Well I opened it again as soon as I sent reply and I still don’t have any lag.

Well, are you thinking Carmar nailed it, then?

I guess. But I won’t close the thread yet in case problem repeats like last time.

1 Like

Two other instances pointing to Discord as the likely cause:


2 Likes

Naughty discord. Alright thank you Carmar for following up! :smiley:

1 Like

Actually, you were the one on your thread who reported the potential bug, so thank you for that.

2 Likes

I totally did not realize that wasn’t my thread hahaha :joy:

A post was split to a new topic: Lag while using VLC